aboutsummaryrefslogtreecommitdiff
path: root/crates/ide/Cargo.toml
diff options
context:
space:
mode:
authorbors[bot] <26634292+bors[bot]@users.noreply.github.com>2020-08-13 16:59:50 +0100
committerGitHub <[email protected]>2020-08-13 16:59:50 +0100
commit018a6cac072767dfd630c22e6d9ce134b7bb09af (patch)
tree4293492e643f9a604c5f30e051289bcea182694c /crates/ide/Cargo.toml
parent00fb411f3edea72a1a9739f7df6f21cca045730b (diff)
parent6bc2633c90cedad057c5201d1ab7f67b57247004 (diff)
Merge #5750
5750: Rename ra_ide -> ide r=matklad a=matklad bors r+ 🤖 Co-authored-by: Aleksey Kladov <[email protected]>
Diffstat (limited to 'crates/ide/Cargo.toml')
-rw-r--r--crates/ide/Cargo.toml35
1 files changed, 35 insertions, 0 deletions
diff --git a/crates/ide/Cargo.toml b/crates/ide/Cargo.toml
new file mode 100644
index 000000000..e4b970c73
--- /dev/null
+++ b/crates/ide/Cargo.toml
@@ -0,0 +1,35 @@
1[package]
2name = "ide"
3version = "0.0.0"
4license = "MIT OR Apache-2.0"
5authors = ["rust-analyzer developers"]
6edition = "2018"
7
8[lib]
9doctest = false
10
11[dependencies]
12either = "1.5.3"
13indexmap = "1.3.2"
14itertools = "0.9.0"
15log = "0.4.8"
16rustc-hash = "1.1.0"
17oorandom = "11.1.2"
18
19stdx = { path = "../stdx" }
20syntax = { path = "../syntax" }
21text_edit = { path = "../text_edit" }
22base_db = { path = "../base_db" }
23ide_db = { path = "../ide_db" }
24cfg = { path = "../cfg" }
25profile = { path = "../profile" }
26test_utils = { path = "../test_utils" }
27assists = { path = "../assists" }
28ssr = { path = "../ssr" }
29
30# ide should depend only on the top-level `hir` package. if you need
31# something from some `hir_xxx` subpackage, reexport the API via `hir`.
32hir = { path = "../hir" }
33
34[dev-dependencies]
35expect = { path = "../expect" }