aboutsummaryrefslogtreecommitdiff
path: root/crates/ide/Cargo.toml
diff options
context:
space:
mode:
authorDmitry <[email protected]>2020-08-14 19:32:05 +0100
committerDmitry <[email protected]>2020-08-14 19:32:05 +0100
commit178c3e135a2a249692f7784712492e7884ae0c00 (patch)
treeac6b769dbf7162150caa0c1624786a4dd79ff3be /crates/ide/Cargo.toml
parent06ff8e6c760ff05f10e868b5d1f9d79e42fbb49c (diff)
parentc2594daf2974dbd4ce3d9b7ec72481764abaceb5 (diff)
Merge remote-tracking branch 'origin/master'
Diffstat (limited to 'crates/ide/Cargo.toml')
-rw-r--r--crates/ide/Cargo.toml35
1 files changed, 35 insertions, 0 deletions
diff --git a/crates/ide/Cargo.toml b/crates/ide/Cargo.toml
new file mode 100644
index 000000000..e4b970c73
--- /dev/null
+++ b/crates/ide/Cargo.toml
@@ -0,0 +1,35 @@
1[package]
2name = "ide"
3version = "0.0.0"
4license = "MIT OR Apache-2.0"
5authors = ["rust-analyzer developers"]
6edition = "2018"
7
8[lib]
9doctest = false
10
11[dependencies]
12either = "1.5.3"
13indexmap = "1.3.2"
14itertools = "0.9.0"
15log = "0.4.8"
16rustc-hash = "1.1.0"
17oorandom = "11.1.2"
18
19stdx = { path = "../stdx" }
20syntax = { path = "../syntax" }
21text_edit = { path = "../text_edit" }
22base_db = { path = "../base_db" }
23ide_db = { path = "../ide_db" }
24cfg = { path = "../cfg" }
25profile = { path = "../profile" }
26test_utils = { path = "../test_utils" }
27assists = { path = "../assists" }
28ssr = { path = "../ssr" }
29
30# ide should depend only on the top-level `hir` package. if you need
31# something from some `hir_xxx` subpackage, reexport the API via `hir`.
32hir = { path = "../hir" }
33
34[dev-dependencies]
35expect = { path = "../expect" }