aboutsummaryrefslogtreecommitdiff
path: root/crates/ide/Cargo.toml
diff options
context:
space:
mode:
authorAleksey Kladov <[email protected]>2020-08-13 16:42:52 +0100
committerAleksey Kladov <[email protected]>2020-08-13 16:58:27 +0100
commit1b0c7701cc97cd7bef8bb9729011d4cf291a60c5 (patch)
treeb69f0c9947d9cec522ce835d7213b21075fe6dcf /crates/ide/Cargo.toml
parentfc34403018079ea053f26d0a31b7517053c7dd8c (diff)
Rename ra_ide -> ide
Diffstat (limited to 'crates/ide/Cargo.toml')
-rw-r--r--crates/ide/Cargo.toml35
1 files changed, 35 insertions, 0 deletions
diff --git a/crates/ide/Cargo.toml b/crates/ide/Cargo.toml
new file mode 100644
index 000000000..e4b970c73
--- /dev/null
+++ b/crates/ide/Cargo.toml
@@ -0,0 +1,35 @@
1[package]
2name = "ide"
3version = "0.0.0"
4license = "MIT OR Apache-2.0"
5authors = ["rust-analyzer developers"]
6edition = "2018"
7
8[lib]
9doctest = false
10
11[dependencies]
12either = "1.5.3"
13indexmap = "1.3.2"
14itertools = "0.9.0"
15log = "0.4.8"
16rustc-hash = "1.1.0"
17oorandom = "11.1.2"
18
19stdx = { path = "../stdx" }
20syntax = { path = "../syntax" }
21text_edit = { path = "../text_edit" }
22base_db = { path = "../base_db" }
23ide_db = { path = "../ide_db" }
24cfg = { path = "../cfg" }
25profile = { path = "../profile" }
26test_utils = { path = "../test_utils" }
27assists = { path = "../assists" }
28ssr = { path = "../ssr" }
29
30# ide should depend only on the top-level `hir` package. if you need
31# something from some `hir_xxx` subpackage, reexport the API via `hir`.
32hir = { path = "../hir" }
33
34[dev-dependencies]
35expect = { path = "../expect" }