aboutsummaryrefslogtreecommitdiff
path: root/crates/ide/Cargo.toml
diff options
context:
space:
mode:
authorZac Pullar-Strecker <[email protected]>2020-08-24 10:19:53 +0100
committerZac Pullar-Strecker <[email protected]>2020-08-24 10:20:13 +0100
commit7bbca7a1b3f9293d2f5cc5745199bc5f8396f2f0 (patch)
treebdb47765991cb973b2cd5481a088fac636bd326c /crates/ide/Cargo.toml
parentca464650eeaca6195891199a93f4f76cf3e7e697 (diff)
parente65d48d1fb3d4d91d9dc1148a7a836ff5c9a3c87 (diff)
Merge remote-tracking branch 'upstream/master' into 503-hover-doc-links
Diffstat (limited to 'crates/ide/Cargo.toml')
-rw-r--r--crates/ide/Cargo.toml37
1 files changed, 37 insertions, 0 deletions
diff --git a/crates/ide/Cargo.toml b/crates/ide/Cargo.toml
new file mode 100644
index 000000000..9ecf43e5a
--- /dev/null
+++ b/crates/ide/Cargo.toml
@@ -0,0 +1,37 @@
1[package]
2name = "ide"
3version = "0.0.0"
4license = "MIT OR Apache-2.0"
5authors = ["rust-analyzer developers"]
6edition = "2018"
7
8[lib]
9doctest = false
10
11[dependencies]
12either = "1.5.3"
13indexmap = "1.3.2"
14itertools = "0.9.0"
15log = "0.4.8"
16rustc-hash = "1.1.0"
17oorandom = "11.1.2"
18pulldown-cmark-to-cmark = "5.0.0"
19pulldown-cmark = {version = "0.7.2", default-features = false}
20
21stdx = { path = "../stdx" }
22syntax = { path = "../syntax" }
23text_edit = { path = "../text_edit" }
24base_db = { path = "../base_db" }
25ide_db = { path = "../ide_db" }
26cfg = { path = "../cfg" }
27profile = { path = "../profile" }
28test_utils = { path = "../test_utils" }
29assists = { path = "../assists" }
30ssr = { path = "../ssr" }
31
32# ide should depend only on the top-level `hir` package. if you need
33# something from some `hir_xxx` subpackage, reexport the API via `hir`.
34hir = { path = "../hir" }
35
36[dev-dependencies]
37expect-test = "0.1"