aboutsummaryrefslogtreecommitdiff
path: root/crates/ide/Cargo.toml
diff options
context:
space:
mode:
authorZac Pullar-Strecker <[email protected]>2020-08-25 05:44:36 +0100
committerZac Pullar-Strecker <[email protected]>2020-08-25 05:44:36 +0100
commitb835f06cecd2189cb32a431fdb85245fbf53032a (patch)
tree8bb4ba65f4922e9cca571a7d4a7fa17d047ae779 /crates/ide/Cargo.toml
parent452afaebe188251cd4403e56999bf8b58de4fba9 (diff)
parentef9cea945d5767e7c60d5931a7649a73caea23ad (diff)
Merge remote-tracking branch 'upstream/master' into 503-hover-doc-links
Diffstat (limited to 'crates/ide/Cargo.toml')
-rw-r--r--crates/ide/Cargo.toml23
1 files changed, 12 insertions, 11 deletions
diff --git a/crates/ide/Cargo.toml b/crates/ide/Cargo.toml
index 9ecf43e5a..e61c276df 100644
--- a/crates/ide/Cargo.toml
+++ b/crates/ide/Cargo.toml
@@ -1,6 +1,7 @@
1[package] 1[package]
2name = "ide" 2name = "ide"
3version = "0.0.0" 3version = "0.0.0"
4description = "TBD"
4license = "MIT OR Apache-2.0" 5license = "MIT OR Apache-2.0"
5authors = ["rust-analyzer developers"] 6authors = ["rust-analyzer developers"]
6edition = "2018" 7edition = "2018"
@@ -18,20 +19,20 @@ oorandom = "11.1.2"
18pulldown-cmark-to-cmark = "5.0.0" 19pulldown-cmark-to-cmark = "5.0.0"
19pulldown-cmark = {version = "0.7.2", default-features = false} 20pulldown-cmark = {version = "0.7.2", default-features = false}
20 21
21stdx = { path = "../stdx" } 22stdx = { path = "../stdx", version = "0.0.0" }
22syntax = { path = "../syntax" } 23syntax = { path = "../syntax", version = "0.0.0" }
23text_edit = { path = "../text_edit" } 24text_edit = { path = "../text_edit", version = "0.0.0" }
24base_db = { path = "../base_db" } 25base_db = { path = "../base_db", version = "0.0.0" }
25ide_db = { path = "../ide_db" } 26ide_db = { path = "../ide_db", version = "0.0.0" }
26cfg = { path = "../cfg" } 27cfg = { path = "../cfg", version = "0.0.0" }
27profile = { path = "../profile" } 28profile = { path = "../profile", version = "0.0.0" }
28test_utils = { path = "../test_utils" } 29test_utils = { path = "../test_utils", version = "0.0.0" }
29assists = { path = "../assists" } 30assists = { path = "../assists", version = "0.0.0" }
30ssr = { path = "../ssr" } 31ssr = { path = "../ssr", version = "0.0.0" }
31 32
32# ide should depend only on the top-level `hir` package. if you need 33# ide should depend only on the top-level `hir` package. if you need
33# something from some `hir_xxx` subpackage, reexport the API via `hir`. 34# something from some `hir_xxx` subpackage, reexport the API via `hir`.
34hir = { path = "../hir" } 35hir = { path = "../hir", version = "0.0.0" }
35 36
36[dev-dependencies] 37[dev-dependencies]
37expect-test = "0.1" 38expect-test = "0.1"