diff options
author | bors[bot] <26634292+bors[bot]@users.noreply.github.com> | 2021-02-22 20:28:17 +0000 |
---|---|---|
committer | GitHub <[email protected]> | 2021-02-22 20:28:17 +0000 |
commit | 27ed1ebf8997cea55fb446ce249b390607b84105 (patch) | |
tree | a49a763fee848041fd607f449ad13a0b1040636e /crates/ide_ssr/Cargo.toml | |
parent | 8687053b118f47ce1a4962d0baa19b22d40d2758 (diff) | |
parent | eb6cfa7f157690480fca5d55c69dba3fae87ad4f (diff) |
Merge #7759
7759: 7526: Rename ide related crates r=Veykril a=chetankhilosiya
renamed assists -> ide_assists and ssr -> ide_ssr.
the completion crate is already renamed.
Co-authored-by: Chetan Khilosiya <[email protected]>
Diffstat (limited to 'crates/ide_ssr/Cargo.toml')
-rw-r--r-- | crates/ide_ssr/Cargo.toml | 24 |
1 files changed, 24 insertions, 0 deletions
diff --git a/crates/ide_ssr/Cargo.toml b/crates/ide_ssr/Cargo.toml new file mode 100644 index 000000000..edbc1846b --- /dev/null +++ b/crates/ide_ssr/Cargo.toml | |||
@@ -0,0 +1,24 @@ | |||
1 | [package] | ||
2 | name = "ide_ssr" | ||
3 | version = "0.0.0" | ||
4 | description = "Structural search and replace of Rust code" | ||
5 | license = "MIT OR Apache-2.0" | ||
6 | repository = "https://github.com/rust-analyzer/rust-analyzer" | ||
7 | authors = ["rust-analyzer developers"] | ||
8 | edition = "2018" | ||
9 | |||
10 | [lib] | ||
11 | doctest = false | ||
12 | |||
13 | [dependencies] | ||
14 | rustc-hash = "1.1.0" | ||
15 | itertools = "0.10.0" | ||
16 | |||
17 | text_edit = { path = "../text_edit", version = "0.0.0" } | ||
18 | syntax = { path = "../syntax", version = "0.0.0" } | ||
19 | ide_db = { path = "../ide_db", version = "0.0.0" } | ||
20 | hir = { path = "../hir", version = "0.0.0" } | ||
21 | test_utils = { path = "../test_utils", version = "0.0.0" } | ||
22 | |||
23 | [dev-dependencies] | ||
24 | expect-test = "1.1" | ||