diff options
author | Pascal Hertleif <[email protected]> | 2018-09-08 15:55:53 +0100 |
---|---|---|
committer | Pascal Hertleif <[email protected]> | 2018-09-08 15:55:53 +0100 |
commit | a37cd5ad43f28e2eddab713266517cf06c256ba7 (patch) | |
tree | 910bfe4935460d6022cfe897897cf84814482d3e /crates/libsyntax2/fuzz/Cargo.toml | |
parent | df05c5c3e20cfdfccd0165dd3370fed7c3676cd0 (diff) |
Add trivial fuzzer for parser
As described in #61, fuzz testing some parts of this would be ~~fun~~
helpful. So, I started with the most trivial fuzzer I could think of:
Put random stuff into File::parse and see what happens.
To speed things up, I also did
cp src/**/*.rs fuzz/corpus/parser/
in the `crates/libsyntax2/` directory (running the fuzzer once will
generate the necessary directories).
Diffstat (limited to 'crates/libsyntax2/fuzz/Cargo.toml')
-rw-r--r-- | crates/libsyntax2/fuzz/Cargo.toml | 22 |
1 files changed, 22 insertions, 0 deletions
diff --git a/crates/libsyntax2/fuzz/Cargo.toml b/crates/libsyntax2/fuzz/Cargo.toml new file mode 100644 index 000000000..916cd5b6f --- /dev/null +++ b/crates/libsyntax2/fuzz/Cargo.toml | |||
@@ -0,0 +1,22 @@ | |||
1 | |||
2 | [package] | ||
3 | name = "libsyntax2-fuzz" | ||
4 | version = "0.0.1" | ||
5 | authors = ["Automatically generated"] | ||
6 | publish = false | ||
7 | |||
8 | [package.metadata] | ||
9 | cargo-fuzz = true | ||
10 | |||
11 | [dependencies.libsyntax2] | ||
12 | path = ".." | ||
13 | [dependencies.libfuzzer-sys] | ||
14 | git = "https://github.com/rust-fuzz/libfuzzer-sys.git" | ||
15 | |||
16 | # Prevent this from interfering with workspaces | ||
17 | [workspace] | ||
18 | members = ["."] | ||
19 | |||
20 | [[bin]] | ||
21 | name = "parser" | ||
22 | path = "fuzz_targets/parser.rs" | ||