aboutsummaryrefslogtreecommitdiff
path: root/crates/proc_macro_api/Cargo.toml
diff options
context:
space:
mode:
authorJay Somedon <[email protected]>2020-12-23 13:24:53 +0000
committerEdwin Cheng <[email protected]>2021-03-04 01:11:33 +0000
commit55d73bc6754c351dead6ab4d4b57ddaa347734d6 (patch)
treeeb6236274e385dfb0e8c74b621506fa9d57add52 /crates/proc_macro_api/Cargo.toml
parent8fd7cd74067445484fbbd3f78e715c4fe24b004c (diff)
Fix multiple issues from code review
* check metadata version * use memmap * use Result instead of unwrap with Jay Somedon <[email protected]>
Diffstat (limited to 'crates/proc_macro_api/Cargo.toml')
-rw-r--r--crates/proc_macro_api/Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/crates/proc_macro_api/Cargo.toml b/crates/proc_macro_api/Cargo.toml
index 5b0a05dff..16fd56c7e 100644
--- a/crates/proc_macro_api/Cargo.toml
+++ b/crates/proc_macro_api/Cargo.toml
@@ -21,3 +21,4 @@ base_db = { path = "../base_db", version = "0.0.0" }
21stdx = { path = "../stdx", version = "0.0.0" } 21stdx = { path = "../stdx", version = "0.0.0" }
22snap = "1" 22snap = "1"
23object = { version = "0.23.0", default-features = false, features = ["std", "read_core", "elf", "macho", "pe", "unaligned"] } 23object = { version = "0.23.0", default-features = false, features = ["std", "read_core", "elf", "macho", "pe", "unaligned"] }
24memmap = "0.7.0"