diff options
author | bors[bot] <26634292+bors[bot]@users.noreply.github.com> | 2021-03-09 20:57:04 +0000 |
---|---|---|
committer | GitHub <[email protected]> | 2021-03-09 20:57:04 +0000 |
commit | 654313dbc7fdfc839b79592c5a06dfe8597d55b3 (patch) | |
tree | 064328d3e2417144ad3de1e4f67b9f82172ccd05 /crates/proc_macro_api/Cargo.toml | |
parent | 4bb120c7a6abed6425534876b86d214440ba1d9a (diff) | |
parent | ad34e79bb9818cc9bf3d0cf746bd052a67c7bab9 (diff) |
Merge #6822
6822: Read version of rustc that compiled proc macro r=edwin0cheng a=jsomedon
Signed-off-by: Jay Somedon <[email protected]>
This PR is to fix #6174.
I basically
* added two methods, `read_version` and `read_section`(used by `read_version`)
* two new crates `snap` and `object` to be used by those two methods
I just noticed that some part of code were auto-reformatted by rust-analyzer on file save. Does it matter?
Co-authored-by: Jay Somedon <[email protected]>
Co-authored-by: Edwin Cheng <[email protected]>
Diffstat (limited to 'crates/proc_macro_api/Cargo.toml')
-rw-r--r-- | crates/proc_macro_api/Cargo.toml | 3 |
1 files changed, 3 insertions, 0 deletions
diff --git a/crates/proc_macro_api/Cargo.toml b/crates/proc_macro_api/Cargo.toml index f09726223..16fd56c7e 100644 --- a/crates/proc_macro_api/Cargo.toml +++ b/crates/proc_macro_api/Cargo.toml | |||
@@ -19,3 +19,6 @@ jod-thread = "0.1.1" | |||
19 | tt = { path = "../tt", version = "0.0.0" } | 19 | tt = { path = "../tt", version = "0.0.0" } |
20 | base_db = { path = "../base_db", version = "0.0.0" } | 20 | base_db = { path = "../base_db", version = "0.0.0" } |
21 | stdx = { path = "../stdx", version = "0.0.0" } | 21 | stdx = { path = "../stdx", version = "0.0.0" } |
22 | snap = "1" | ||
23 | object = { version = "0.23.0", default-features = false, features = ["std", "read_core", "elf", "macho", "pe", "unaligned"] } | ||
24 | memmap = "0.7.0" | ||