aboutsummaryrefslogtreecommitdiff
path: root/crates/proc_macro_api/Cargo.toml
diff options
context:
space:
mode:
authorbors[bot] <26634292+bors[bot]@users.noreply.github.com>2020-12-07 16:21:51 +0000
committerGitHub <[email protected]>2020-12-07 16:21:51 +0000
commitc1824b4933f7a30b4253116290a0a6b2935eedc3 (patch)
tree30b2e506e326af121a716c92d42fc90229179072 /crates/proc_macro_api/Cargo.toml
parent9a88332452d661d4afea10f0063c893142e08019 (diff)
parent577d5f1c337d5de8719bddcabd3d22a560a11b95 (diff)
Merge #6745
6745: Some more proc macro cleanups r=jonas-schievink a=jonas-schievink * Remove `ProcMacroClient::dummy` and just use `Option<ProcMacroClient>` instead * Remember the type of proc macros (later allows us to reject using an incorrect macro type) * Prepare a few internals for procedural attribute macros bors r+ Co-authored-by: Jonas Schievink <[email protected]>
Diffstat (limited to 'crates/proc_macro_api/Cargo.toml')
-rw-r--r--crates/proc_macro_api/Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/crates/proc_macro_api/Cargo.toml b/crates/proc_macro_api/Cargo.toml
index 3863e5189..1af2bbca7 100644
--- a/crates/proc_macro_api/Cargo.toml
+++ b/crates/proc_macro_api/Cargo.toml
@@ -17,3 +17,4 @@ crossbeam-channel = "0.5.0"
17jod-thread = "0.1.1" 17jod-thread = "0.1.1"
18 18
19tt = { path = "../tt", version = "0.0.0" } 19tt = { path = "../tt", version = "0.0.0" }
20base_db = { path = "../base_db", version = "0.0.0" }