aboutsummaryrefslogtreecommitdiff
path: root/crates/proc_macro_srv/Cargo.toml
diff options
context:
space:
mode:
authorDmitry <[email protected]>2020-08-14 19:32:05 +0100
committerDmitry <[email protected]>2020-08-14 19:32:05 +0100
commit178c3e135a2a249692f7784712492e7884ae0c00 (patch)
treeac6b769dbf7162150caa0c1624786a4dd79ff3be /crates/proc_macro_srv/Cargo.toml
parent06ff8e6c760ff05f10e868b5d1f9d79e42fbb49c (diff)
parentc2594daf2974dbd4ce3d9b7ec72481764abaceb5 (diff)
Merge remote-tracking branch 'origin/master'
Diffstat (limited to 'crates/proc_macro_srv/Cargo.toml')
-rw-r--r--crates/proc_macro_srv/Cargo.toml27
1 files changed, 27 insertions, 0 deletions
diff --git a/crates/proc_macro_srv/Cargo.toml b/crates/proc_macro_srv/Cargo.toml
new file mode 100644
index 000000000..7171f0808
--- /dev/null
+++ b/crates/proc_macro_srv/Cargo.toml
@@ -0,0 +1,27 @@
1[package]
2name = "proc_macro_srv"
3version = "0.0.0"
4license = "MIT OR Apache-2.0"
5authors = ["rust-analyzer developers"]
6edition = "2018"
7
8[lib]
9doctest = false
10
11[dependencies]
12goblin = "0.2.1"
13libloading = "0.6.0"
14memmap = "0.7"
15
16tt = { path = "../tt" }
17mbe = { path = "../mbe" }
18proc_macro_api = { path = "../proc_macro_api" }
19test_utils = { path = "../test_utils" }
20
21[dev-dependencies]
22cargo_metadata = "0.11.1"
23difference = "2.0.0"
24# used as proc macro test target
25serde_derive = "1.0.106"
26
27toolchain = { path = "../toolchain" }