aboutsummaryrefslogtreecommitdiff
path: root/crates/proc_macro_test/Cargo.toml
diff options
context:
space:
mode:
authorbors[bot] <26634292+bors[bot]@users.noreply.github.com>2021-06-11 11:44:07 +0100
committerGitHub <[email protected]>2021-06-11 11:44:07 +0100
commit050232a37e71ec06e8810af29178b124c76a527d (patch)
tree6fddd9fbac95b72b24f0024586fe6d0c985aa429 /crates/proc_macro_test/Cargo.toml
parentde9e989cf4435c58b8347b16881e50d06f754f20 (diff)
parentd236fc6abecb308dab5e21898fa40f3bddf27640 (diff)
Merge #9192
9192: internal: Build test-macros in a build script r=jonas-schievink a=jonas-schievink This build the test-proc-macros in `proc_macro_test` in a build script, and copies the artifact to `OUT_DIR`. This should make it available throughout all of rust-analyzer at no cost other than depending on `proc_macro_test`, fixing https://github.com/rust-analyzer/rust-analyzer/issues/9067. This hopefully will let us later write inline tests that utilize proc macros, which makes my life fixing proc macro bugs easier. Opening this as a sort of RFC, because I'm not totally sure this approach is the best. Co-authored-by: Jonas Schievink <[email protected]>
Diffstat (limited to 'crates/proc_macro_test/Cargo.toml')
-rw-r--r--crates/proc_macro_test/Cargo.toml6
1 files changed, 5 insertions, 1 deletions
diff --git a/crates/proc_macro_test/Cargo.toml b/crates/proc_macro_test/Cargo.toml
index 753443be2..1a88e361e 100644
--- a/crates/proc_macro_test/Cargo.toml
+++ b/crates/proc_macro_test/Cargo.toml
@@ -8,4 +8,8 @@ publish = false
8 8
9[lib] 9[lib]
10doctest = false 10doctest = false
11proc-macro = true 11
12[build-dependencies]
13proc_macro_test_impl = { path = "imp", version = "0.0.0" }
14toolchain = { path = "../toolchain", version = "0.0.0" }
15cargo_metadata = "0.13"