aboutsummaryrefslogtreecommitdiff
path: root/crates/profile/Cargo.toml
diff options
context:
space:
mode:
authorbors[bot] <26634292+bors[bot]@users.noreply.github.com>2021-01-18 18:40:14 +0000
committerGitHub <[email protected]>2021-01-18 18:40:14 +0000
commit08efb8a94360735f505699021eaa901464c76f4a (patch)
tree29704f0e4140261ed68bb5ea3cf52e7385bfc997 /crates/profile/Cargo.toml
parent6764d790ac904533dc7618fd38724a135499f87c (diff)
parent9b5fa1c61a85972da419aa29d61286cb9e268f83 (diff)
Merge #7334
7334: Add back jemalloc support r=jonas-schievink a=jonas-schievink jemalloc is useful due to its introspection API, which allows obtaining quick and accurate memory usage statistics without running into `mallinfo`'s limitations. Co-authored-by: Jonas Schievink <[email protected]>
Diffstat (limited to 'crates/profile/Cargo.toml')
-rw-r--r--crates/profile/Cargo.toml2
1 files changed, 2 insertions, 0 deletions
diff --git a/crates/profile/Cargo.toml b/crates/profile/Cargo.toml
index 9c7ce26be..f7231c2b8 100644
--- a/crates/profile/Cargo.toml
+++ b/crates/profile/Cargo.toml
@@ -14,12 +14,14 @@ once_cell = "1.3.1"
14cfg-if = "1" 14cfg-if = "1"
15libc = "0.2.73" 15libc = "0.2.73"
16la-arena = { version = "0.2.0", path = "../../lib/arena" } 16la-arena = { version = "0.2.0", path = "../../lib/arena" }
17jemalloc-ctl = { version = "0.3.3", optional = true }
17 18
18[target.'cfg(target_os = "linux")'.dependencies] 19[target.'cfg(target_os = "linux")'.dependencies]
19perf-event = "0.4" 20perf-event = "0.4"
20 21
21[features] 22[features]
22cpu_profiler = [] 23cpu_profiler = []
24jemalloc = ["jemalloc-ctl"]
23 25
24# Uncomment to enable for the whole crate graph 26# Uncomment to enable for the whole crate graph
25# default = [ "cpu_profiler" ] 27# default = [ "cpu_profiler" ]