aboutsummaryrefslogtreecommitdiff
path: root/crates/profile/Cargo.toml
diff options
context:
space:
mode:
authorAleksey Kladov <[email protected]>2020-08-12 15:32:36 +0100
committerAleksey Kladov <[email protected]>2020-08-12 15:35:29 +0100
commit208b7bd7ba687fb570feb1b89219f14c63712ce8 (patch)
treec39749d1b71b73b4017c2d0d848ebdc85e570c39 /crates/profile/Cargo.toml
parent98baa9b569b49162392ed4149dd435854fe941b8 (diff)
Rename ra_prof -> profile
Diffstat (limited to 'crates/profile/Cargo.toml')
-rw-r--r--crates/profile/Cargo.toml27
1 files changed, 27 insertions, 0 deletions
diff --git a/crates/profile/Cargo.toml b/crates/profile/Cargo.toml
new file mode 100644
index 000000000..e271e3a56
--- /dev/null
+++ b/crates/profile/Cargo.toml
@@ -0,0 +1,27 @@
1[package]
2name = "profile"
3version = "0.0.0"
4license = "MIT OR Apache-2.0"
5authors = ["rust-analyzer developers"]
6edition = "2018"
7
8[lib]
9doctest = false
10
11[dependencies]
12once_cell = "1.3.1"
13cfg-if = "0.1.10"
14libc = "0.2.73"
15backtrace = { version = "0.3.44", optional = true }
16
17arena = { path = "../arena" }
18
19[target.'cfg(target_os = "linux")'.dependencies]
20perf-event = "0.4"
21
22[features]
23cpu_profiler = []
24
25# Uncomment to enable for the whole crate graph
26# default = [ "backtrace" ]
27# default = [ "cpu_profiler" ]