aboutsummaryrefslogtreecommitdiff
path: root/crates/profile/Cargo.toml
diff options
context:
space:
mode:
authorJohn Renner <[email protected]>2021-05-07 20:17:37 +0100
committerJohn Renner <[email protected]>2021-05-07 20:17:37 +0100
commitd8a9b450a6b5190effbe606dc8c49af726f93000 (patch)
treecad73531eeed3bedbf940447a5896bc23f88963a /crates/profile/Cargo.toml
parent1ec82d4bdf47fa5ec1f8599757bbadae274d4f5a (diff)
Switch from jemalloc to tikv-jemalloc
Diffstat (limited to 'crates/profile/Cargo.toml')
-rw-r--r--crates/profile/Cargo.toml4
1 files changed, 2 insertions, 2 deletions
diff --git a/crates/profile/Cargo.toml b/crates/profile/Cargo.toml
index 486f9c164..98df79a8f 100644
--- a/crates/profile/Cargo.toml
+++ b/crates/profile/Cargo.toml
@@ -15,14 +15,14 @@ cfg-if = "1"
15libc = "0.2.73" 15libc = "0.2.73"
16la-arena = { version = "0.2.0", path = "../../lib/arena" } 16la-arena = { version = "0.2.0", path = "../../lib/arena" }
17countme = { version = "2.0.1", features = ["enable"] } 17countme = { version = "2.0.1", features = ["enable"] }
18jemalloc-ctl = { version = "0.3.3", optional = true } 18tikv-jemalloc-ctl = { version = "0.4.1", optional = true }
19 19
20[target.'cfg(target_os = "linux")'.dependencies] 20[target.'cfg(target_os = "linux")'.dependencies]
21perf-event = "0.4" 21perf-event = "0.4"
22 22
23[features] 23[features]
24cpu_profiler = [] 24cpu_profiler = []
25jemalloc = ["jemalloc-ctl"] 25jemalloc = ["tikv-jemalloc-ctl"]
26 26
27# Uncomment to enable for the whole crate graph 27# Uncomment to enable for the whole crate graph
28# default = [ "cpu_profiler" ] 28# default = [ "cpu_profiler" ]