aboutsummaryrefslogtreecommitdiff
path: root/crates/project_model/Cargo.toml
diff options
context:
space:
mode:
authorbors[bot] <26634292+bors[bot]@users.noreply.github.com>2020-12-10 18:30:11 +0000
committerGitHub <[email protected]>2020-12-10 18:30:11 +0000
commit41321d96789ed918eebda02ada76758765d19d16 (patch)
tree1d2b0272f9ae48e143b2e6fa7260c6664eb40b03 /crates/project_model/Cargo.toml
parent814e31957ea0e063272132afd15c3e8f4ed54454 (diff)
parent4d4b91117a02b55e913216459ae661d8dd166579 (diff)
Merge #6807
6807: Replicate Cargo environment variables r=jonas-schievink a=jonas-schievink These might be relied on by procedural macros, and can also be accessed via `env!`. Required for fixing https://github.com/rust-analyzer/rust-analyzer/issues/6696. We do not yet propagate these to any proc macros though. Co-authored-by: Jonas Schievink <[email protected]>
Diffstat (limited to 'crates/project_model/Cargo.toml')
-rw-r--r--crates/project_model/Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/crates/project_model/Cargo.toml b/crates/project_model/Cargo.toml
index e0c591603..c55e85709 100644
--- a/crates/project_model/Cargo.toml
+++ b/crates/project_model/Cargo.toml
@@ -16,6 +16,7 @@ cargo_metadata = "=0.12.0"
16serde = { version = "1.0.106", features = ["derive"] } 16serde = { version = "1.0.106", features = ["derive"] }
17serde_json = "1.0.48" 17serde_json = "1.0.48"
18anyhow = "1.0.26" 18anyhow = "1.0.26"
19itertools = "0.9.0"
19 20
20arena = { path = "../arena", version = "0.0.0" } 21arena = { path = "../arena", version = "0.0.0" }
21cfg = { path = "../cfg", version = "0.0.0" } 22cfg = { path = "../cfg", version = "0.0.0" }