aboutsummaryrefslogtreecommitdiff
path: root/crates/project_model/Cargo.toml
diff options
context:
space:
mode:
authorZac Pullar-Strecker <[email protected]>2020-08-24 10:19:53 +0100
committerZac Pullar-Strecker <[email protected]>2020-08-24 10:20:13 +0100
commit7bbca7a1b3f9293d2f5cc5745199bc5f8396f2f0 (patch)
treebdb47765991cb973b2cd5481a088fac636bd326c /crates/project_model/Cargo.toml
parentca464650eeaca6195891199a93f4f76cf3e7e697 (diff)
parente65d48d1fb3d4d91d9dc1148a7a836ff5c9a3c87 (diff)
Merge remote-tracking branch 'upstream/master' into 503-hover-doc-links
Diffstat (limited to 'crates/project_model/Cargo.toml')
-rw-r--r--crates/project_model/Cargo.toml25
1 files changed, 25 insertions, 0 deletions
diff --git a/crates/project_model/Cargo.toml b/crates/project_model/Cargo.toml
new file mode 100644
index 000000000..386f72f41
--- /dev/null
+++ b/crates/project_model/Cargo.toml
@@ -0,0 +1,25 @@
1[package]
2name = "project_model"
3version = "0.0.0"
4license = "MIT OR Apache-2.0"
5authors = ["rust-analyzer developers"]
6edition = "2018"
7
8[lib]
9doctest = false
10
11[dependencies]
12log = "0.4.8"
13rustc-hash = "1.1.0"
14cargo_metadata = "0.11.1"
15serde = { version = "1.0.106", features = ["derive"] }
16serde_json = "1.0.48"
17anyhow = "1.0.26"
18
19arena = { path = "../arena" }
20cfg = { path = "../cfg" }
21base_db = { path = "../base_db" }
22toolchain = { path = "../toolchain" }
23proc_macro_api = { path = "../proc_macro_api" }
24paths = { path = "../paths" }
25stdx = { path = "../stdx" }