aboutsummaryrefslogtreecommitdiff
path: root/crates/project_model/Cargo.toml
diff options
context:
space:
mode:
authorPavan Kumar Sunkara <[email protected]>2020-08-13 11:05:30 +0100
committerPavan Kumar Sunkara <[email protected]>2020-08-13 11:05:30 +0100
commiteac24d52e672c0a9c118e8969bf1b839c3e7f1f3 (patch)
tree4e1218cc53bef75f54df35be80c6a254b85b8d9c /crates/project_model/Cargo.toml
parentb5cb16fb90b4a1076604c5795552ee4abe07a057 (diff)
Rename ra_project_model -> project_model
Diffstat (limited to 'crates/project_model/Cargo.toml')
-rw-r--r--crates/project_model/Cargo.toml25
1 files changed, 25 insertions, 0 deletions
diff --git a/crates/project_model/Cargo.toml b/crates/project_model/Cargo.toml
new file mode 100644
index 000000000..8d8d09387
--- /dev/null
+++ b/crates/project_model/Cargo.toml
@@ -0,0 +1,25 @@
1[package]
2name = "project_model"
3version = "0.0.0"
4license = "MIT OR Apache-2.0"
5authors = ["rust-analyzer developers"]
6edition = "2018"
7
8[lib]
9doctest = false
10
11[dependencies]
12log = "0.4.8"
13rustc-hash = "1.1.0"
14cargo_metadata = "0.11.1"
15serde = { version = "1.0.106", features = ["derive"] }
16serde_json = "1.0.48"
17anyhow = "1.0.26"
18
19arena = { path = "../arena" }
20cfg = { path = "../cfg" }
21ra_db = { path = "../ra_db" }
22toolchain = { path = "../toolchain" }
23ra_proc_macro = { path = "../ra_proc_macro" }
24paths = { path = "../paths" }
25stdx = { path = "../stdx" }