aboutsummaryrefslogtreecommitdiff
path: root/crates/ra_assists/Cargo.toml
diff options
context:
space:
mode:
authorAleksey Kladov <[email protected]>2020-02-06 13:55:10 +0000
committerAleksey Kladov <[email protected]>2020-02-06 13:55:10 +0000
commitec6fb8da7c7a5529e1db30c0a6f7e2cda6a75d19 (patch)
tree9619fde70cadd5bb3ba654527b4f22b5eebdd012 /crates/ra_assists/Cargo.toml
parentea9d18ba836a7228f7310e1bc77c0918f0191a42 (diff)
Add profiling around add_impl_members
This intention is pretty slow for `impl Interator`, because it has a ton of default methods which need to be substituted. The proper fix here is to not compute the actual edit until the user triggers the action, but that's awkward to do in the LSP right now, so let's just put a profiling code for now.
Diffstat (limited to 'crates/ra_assists/Cargo.toml')
-rw-r--r--crates/ra_assists/Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/crates/ra_assists/Cargo.toml b/crates/ra_assists/Cargo.toml
index 0d2109e4e..9d3091b91 100644
--- a/crates/ra_assists/Cargo.toml
+++ b/crates/ra_assists/Cargo.toml
@@ -16,6 +16,7 @@ either = "1.5"
16ra_syntax = { path = "../ra_syntax" } 16ra_syntax = { path = "../ra_syntax" }
17ra_text_edit = { path = "../ra_text_edit" } 17ra_text_edit = { path = "../ra_text_edit" }
18ra_fmt = { path = "../ra_fmt" } 18ra_fmt = { path = "../ra_fmt" }
19ra_prof = { path = "../ra_prof" }
19ra_db = { path = "../ra_db" } 20ra_db = { path = "../ra_db" }
20hir = { path = "../ra_hir", package = "ra_hir" } 21hir = { path = "../ra_hir", package = "ra_hir" }
21test_utils = { path = "../test_utils" } 22test_utils = { path = "../test_utils" }