aboutsummaryrefslogtreecommitdiff
path: root/crates/ra_cli/Cargo.toml
diff options
context:
space:
mode:
authorFlorian Diebold <[email protected]>2020-02-15 17:00:14 +0000
committerFlorian Diebold <[email protected]>2020-02-15 17:04:01 +0000
commit3484d727c3b26e9596ec3bd671e2a76a87cdb5fd (patch)
treeb0a1561d8dec30fc07bee0cfc2fb93cf6e162c2f /crates/ra_cli/Cargo.toml
parent58f4dcf79ecf3b8dcec83d46a27a29340900a0ef (diff)
Extend analysis-stats a bit
This adds some tools helpful when debugging nondeterminism in analysis-stats: - a `--randomize` option that analyses everything in random order - a `-vv` option that prints even more detail Also add a debug log if Chalk fuel is exhausted (which would be a source of nondeterminism, but didn't happen in my tests). I found one source of nondeterminism (rust-lang/chalk#331), but there are still other cases remaining.
Diffstat (limited to 'crates/ra_cli/Cargo.toml')
-rw-r--r--crates/ra_cli/Cargo.toml2
1 files changed, 2 insertions, 0 deletions
diff --git a/crates/ra_cli/Cargo.toml b/crates/ra_cli/Cargo.toml
index bcd408421..53d4876f6 100644
--- a/crates/ra_cli/Cargo.toml
+++ b/crates/ra_cli/Cargo.toml
@@ -6,8 +6,10 @@ authors = ["rust-analyzer developers"]
6publish = false 6publish = false
7 7
8[dependencies] 8[dependencies]
9itertools = "0.8.0"
9pico-args = "0.3.0" 10pico-args = "0.3.0"
10env_logger = { version = "0.7.1", default-features = false } 11env_logger = { version = "0.7.1", default-features = false }
12rand = { version = "0.7.0", features = ["small_rng"] }
11 13
12ra_syntax = { path = "../ra_syntax" } 14ra_syntax = { path = "../ra_syntax" }
13ra_ide = { path = "../ra_ide" } 15ra_ide = { path = "../ra_ide" }