aboutsummaryrefslogtreecommitdiff
path: root/crates/ra_flycheck/Cargo.toml
diff options
context:
space:
mode:
authorAleksey Kladov <[email protected]>2020-05-15 00:51:48 +0100
committerAleksey Kladov <[email protected]>2020-05-15 00:52:25 +0100
commit220813dcb0881ff199619c11eb34a39a6de0f67a (patch)
treebf2bcdce03889a356b37bfe29253de4228ded6ea /crates/ra_flycheck/Cargo.toml
parent12d82687cd600ec81bf3027661135e5f0d4ad4bd (diff)
Move LSP bits from flycheck to rust-analyzer
There should be only one place that knows about LSP, and that place is right before we spit JSON on stdout.
Diffstat (limited to 'crates/ra_flycheck/Cargo.toml')
-rw-r--r--crates/ra_flycheck/Cargo.toml4
1 files changed, 0 insertions, 4 deletions
diff --git a/crates/ra_flycheck/Cargo.toml b/crates/ra_flycheck/Cargo.toml
index eac502da5..1aa39bade 100644
--- a/crates/ra_flycheck/Cargo.toml
+++ b/crates/ra_flycheck/Cargo.toml
@@ -9,12 +9,8 @@ doctest = false
9 9
10[dependencies] 10[dependencies]
11crossbeam-channel = "0.4.0" 11crossbeam-channel = "0.4.0"
12lsp-types = { version = "0.74.0", features = ["proposed"] }
13log = "0.4.8" 12log = "0.4.8"
14cargo_metadata = "0.10.0" 13cargo_metadata = "0.10.0"
15serde_json = "1.0.48" 14serde_json = "1.0.48"
16jod-thread = "0.1.1" 15jod-thread = "0.1.1"
17ra_toolchain = { path = "../ra_toolchain" } 16ra_toolchain = { path = "../ra_toolchain" }
18
19[dev-dependencies]
20insta = "0.16.0"