aboutsummaryrefslogtreecommitdiff
path: root/crates/ra_flycheck/Cargo.toml
diff options
context:
space:
mode:
authorbors[bot] <26634292+bors[bot]@users.noreply.github.com>2020-05-08 11:11:19 +0100
committerGitHub <[email protected]>2020-05-08 11:11:19 +0100
commit8295a9340c1fbda805497035054ead0b10c0d88e (patch)
treeccab3f149b9633ae95570d78fa5d6b8d3b3392e6 /crates/ra_flycheck/Cargo.toml
parent363c1f2f493d206f2cc10c348a02f3efadd8c77a (diff)
parent3077eae2a61f97c28c0d4e3456f6ab873126e5b8 (diff)
Merge #4329
4329: Look for `cargo`, `rustc`, and `rustup` in standard installation path r=matklad a=cdisselkoen Discussed in #3118. This is approximately a 90% fix for the issue described there. This PR creates a new crate `ra_env` with a function `get_path_for_executable()`; see docs there. `get_path_for_executable()` improves and generalizes the function `cargo_binary()` which was previously duplicated in the `ra_project_model` and `ra_flycheck` crates. (Both of those crates now depend on the new `ra_env` crate.) The new function checks (e.g.) `$CARGO` and `$PATH`, but also falls back on `~/.cargo/bin` manually before erroring out. This should allow most users to not have to worry about setting the `$CARGO` or `$PATH` variables for VSCode, which can be difficult e.g. on macOS as discussed in #3118. I've attempted to replace all calls to `cargo`, `rustc`, and `rustup` in rust-analyzer with appropriate invocations of `get_path_for_executable()`; I don't think I've missed any in Rust code, but there is at least one invocation in TypeScript code which I haven't fixed. (I'm not sure whether it's affected by the same problem or not.) https://github.com/rust-analyzer/rust-analyzer/blob/a4778ddb7a00f552a8e653bbf56ae9fd69cfe1d3/editors/code/src/cargo.ts#L79 I'm sure this PR could be improved a bunch, so I'm happy to take feedback/suggestions on how to solve this problem better, or just bikeshedding variable/function/crate names etc. cc @Veetaha Fixes #3118. Co-authored-by: Craig Disselkoen <[email protected]> Co-authored-by: veetaha <[email protected]>
Diffstat (limited to 'crates/ra_flycheck/Cargo.toml')
-rw-r--r--crates/ra_flycheck/Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/crates/ra_flycheck/Cargo.toml b/crates/ra_flycheck/Cargo.toml
index 3d5093264..d0f7fb2dc 100644
--- a/crates/ra_flycheck/Cargo.toml
+++ b/crates/ra_flycheck/Cargo.toml
@@ -14,6 +14,7 @@ log = "0.4.8"
14cargo_metadata = "0.9.1" 14cargo_metadata = "0.9.1"
15serde_json = "1.0.48" 15serde_json = "1.0.48"
16jod-thread = "0.1.1" 16jod-thread = "0.1.1"
17ra_env = { path = "../ra_env" }
17 18
18[dev-dependencies] 19[dev-dependencies]
19insta = "0.16.0" 20insta = "0.16.0"