aboutsummaryrefslogtreecommitdiff
path: root/crates/ra_hir_ty/Cargo.toml
diff options
context:
space:
mode:
authorbors[bot] <26634292+bors[bot]@users.noreply.github.com>2019-11-26 12:42:15 +0000
committerGitHub <[email protected]>2019-11-26 12:42:15 +0000
commit36dca8de93c07be62724f973aa4c8a045941d218 (patch)
treedbe3d521c869aa12c922098e9544859343494a0e /crates/ra_hir_ty/Cargo.toml
parent280946e597f880709d2dc2e12eb9a6db3223d979 (diff)
parent4e17718a9aaba34533ba6a46d52b4aa959c662c7 (diff)
Merge #2410
2410: Introduce hir_ty r=matklad a=matklad Co-authored-by: Aleksey Kladov <[email protected]>
Diffstat (limited to 'crates/ra_hir_ty/Cargo.toml')
-rw-r--r--crates/ra_hir_ty/Cargo.toml32
1 files changed, 32 insertions, 0 deletions
diff --git a/crates/ra_hir_ty/Cargo.toml b/crates/ra_hir_ty/Cargo.toml
new file mode 100644
index 000000000..70216ab24
--- /dev/null
+++ b/crates/ra_hir_ty/Cargo.toml
@@ -0,0 +1,32 @@
1[package]
2edition = "2018"
3name = "ra_hir_ty"
4version = "0.1.0"
5authors = ["rust-analyzer developers"]
6
7[lib]
8doctest = false
9
10[dependencies]
11log = "0.4.5"
12rustc-hash = "1.0"
13parking_lot = "0.9.0"
14ena = "0.13"
15
16ra_syntax = { path = "../ra_syntax" }
17ra_arena = { path = "../ra_arena" }
18ra_db = { path = "../ra_db" }
19hir_expand = { path = "../ra_hir_expand", package = "ra_hir_expand" }
20hir_def = { path = "../ra_hir_def", package = "ra_hir_def" }
21test_utils = { path = "../test_utils" }
22ra_prof = { path = "../ra_prof" }
23
24# https://github.com/rust-lang/chalk/pull/294
25chalk-solve = { git = "https://github.com/jackh726/chalk.git", rev = "095cd38a4f16337913bba487f2055b9ca0179f30" }
26chalk-rust-ir = { git = "https://github.com/jackh726/chalk.git", rev = "095cd38a4f16337913bba487f2055b9ca0179f30" }
27chalk-ir = { git = "https://github.com/jackh726/chalk.git", rev = "095cd38a4f16337913bba487f2055b9ca0179f30" }
28
29lalrpop-intern = "0.15.1"
30
31[dev-dependencies]
32insta = "0.12.0"