diff options
author | bors[bot] <26634292+bors[bot]@users.noreply.github.com> | 2019-11-27 18:45:05 +0000 |
---|---|---|
committer | GitHub <[email protected]> | 2019-11-27 18:45:05 +0000 |
commit | 360f6b7bb32d6280ed787075c4a54f4e5b46fcb6 (patch) | |
tree | 4c059427819ef442c785125f48fe83f81f6d667a /crates/ra_ide/Cargo.toml | |
parent | 4946169a96f3d442f463724af481fdb760381ccb (diff) | |
parent | 27b362b05910c81fd5b28f6cd5d2c075311032f9 (diff) |
Merge #2430
2430: rename ra_ide_api -> ra_ide r=matklad a=matklad
Co-authored-by: Aleksey Kladov <[email protected]>
Diffstat (limited to 'crates/ra_ide/Cargo.toml')
-rw-r--r-- | crates/ra_ide/Cargo.toml | 46 |
1 files changed, 46 insertions, 0 deletions
diff --git a/crates/ra_ide/Cargo.toml b/crates/ra_ide/Cargo.toml new file mode 100644 index 000000000..e6383dd35 --- /dev/null +++ b/crates/ra_ide/Cargo.toml | |||
@@ -0,0 +1,46 @@ | |||
1 | [package] | ||
2 | edition = "2018" | ||
3 | name = "ra_ide" | ||
4 | version = "0.1.0" | ||
5 | authors = ["rust-analyzer developers"] | ||
6 | |||
7 | [lib] | ||
8 | doctest = false | ||
9 | |||
10 | [features] | ||
11 | wasm = [] | ||
12 | |||
13 | [dependencies] | ||
14 | format-buf = "1.0.0" | ||
15 | itertools = "0.8.0" | ||
16 | join_to_string = "0.1.3" | ||
17 | log = "0.4.5" | ||
18 | rayon = "1.0.2" | ||
19 | fst = { version = "0.3.1", default-features = false } | ||
20 | rustc-hash = "1.0" | ||
21 | unicase = "2.2.0" | ||
22 | superslice = "1.0.0" | ||
23 | rand = { version = "0.7.0", features = ["small_rng"] } | ||
24 | once_cell = "1.2.0" | ||
25 | |||
26 | ra_syntax = { path = "../ra_syntax" } | ||
27 | ra_text_edit = { path = "../ra_text_edit" } | ||
28 | ra_db = { path = "../ra_db" } | ||
29 | ra_cfg = { path = "../ra_cfg" } | ||
30 | ra_fmt = { path = "../ra_fmt" } | ||
31 | ra_prof = { path = "../ra_prof" } | ||
32 | test_utils = { path = "../test_utils" } | ||
33 | ra_assists = { path = "../ra_assists" } | ||
34 | |||
35 | # ra_ide should depend only on the top-level `hir` package. if you need | ||
36 | # something from some `hir_xxx` subpackage, reexport the API via `hir`. | ||
37 | hir = { path = "../ra_hir", package = "ra_hir" } | ||
38 | |||
39 | [dev-dependencies] | ||
40 | insta = "0.12.0" | ||
41 | |||
42 | [dev-dependencies.proptest] | ||
43 | version = "0.9.0" | ||
44 | # Disable `fork` feature to allow compiling on webassembly | ||
45 | default-features = false | ||
46 | features = ["std", "bit-set", "break-dead-code"] | ||