aboutsummaryrefslogtreecommitdiff
path: root/crates/ra_ide_api/Cargo.toml
diff options
context:
space:
mode:
authorbors[bot] <bors[bot]@users.noreply.github.com>2019-03-22 20:22:37 +0000
committerbors[bot] <bors[bot]@users.noreply.github.com>2019-03-22 20:22:37 +0000
commit15189bc7249fc68a1df0234721514b677a90a305 (patch)
tree59b6168c1c2c6cd376d443b8da3383fcf87b826b /crates/ra_ide_api/Cargo.toml
parent3604f23e98d01fe9d89e5cdcf76a51cb9c1d6768 (diff)
parent4e6d0933cce60a883fc6b58d12523acf72d9756a (diff)
Merge #1021
1021: Wasm dependencies r=matklad a=detrumi As a first step towards running RA on WASM (see #1007), this tweaks the dependencies somewhat so that projects built using `wasm-pack` can use `ra_ide_api` as a dependency. There were two problems: - use of undeclared type or module `MmapInner` This error occurred because of the `memmap` crate, as a dependency of `fst` Solution: specify `default-features = false` for the `fst` package (see https://github.com/BurntSushi/fst/issues/70) - use of undeclared type or module `imp` This happened in the `wait-timeout` crate ([which uses `Command` under the hood](https://github.com/alexcrichton/wait-timeout/issues/18)), a dependency of `rusty-fork` which is a dependency of `proptest`. Solution: move `proptest` to dev-dependencies and add `#[cfg(test)]` to the `test_utils` crate. **Edit:** Oh, that causes trouble with resolving the import when running the tests. Hmm... Co-authored-by: Wilco Kusee <[email protected]>
Diffstat (limited to 'crates/ra_ide_api/Cargo.toml')
-rw-r--r--crates/ra_ide_api/Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/crates/ra_ide_api/Cargo.toml b/crates/ra_ide_api/Cargo.toml
index 8bd5eec2b..97c8bab18 100644
--- a/crates/ra_ide_api/Cargo.toml
+++ b/crates/ra_ide_api/Cargo.toml
@@ -10,7 +10,7 @@ join_to_string = "0.1.3"
10log = "0.4.5" 10log = "0.4.5"
11relative-path = "0.4.0" 11relative-path = "0.4.0"
12rayon = "1.0.2" 12rayon = "1.0.2"
13fst = "0.3.1" 13fst = { version = "0.3.1", default-features = false }
14rustc-hash = "1.0" 14rustc-hash = "1.0"
15parking_lot = "0.7.0" 15parking_lot = "0.7.0"
16unicase = "2.2.0" 16unicase = "2.2.0"