aboutsummaryrefslogtreecommitdiff
path: root/crates/ra_ide_api/Cargo.toml
diff options
context:
space:
mode:
authorbors[bot] <bors[bot]@users.noreply.github.com>2019-01-28 12:52:45 +0000
committerbors[bot] <bors[bot]@users.noreply.github.com>2019-01-28 12:52:45 +0000
commitebb19bb95c79671d5ef1e21a8fcb4daafc356490 (patch)
treedaa75c52c641577945c44b0d4f9838772341988f /crates/ra_ide_api/Cargo.toml
parent3432c4366f578b4f0a9a6e0384292d72e43ebf03 (diff)
parent2ee08098a6315aaab07f14c67db024ee0e95af3e (diff)
Merge #697
697: opt-in jemalloc r=matklad a=matklad Co-authored-by: Aleksey Kladov <[email protected]>
Diffstat (limited to 'crates/ra_ide_api/Cargo.toml')
-rw-r--r--crates/ra_ide_api/Cargo.toml8
1 files changed, 6 insertions, 2 deletions
diff --git a/crates/ra_ide_api/Cargo.toml b/crates/ra_ide_api/Cargo.toml
index ad9dd2088..908899129 100644
--- a/crates/ra_ide_api/Cargo.toml
+++ b/crates/ra_ide_api/Cargo.toml
@@ -14,8 +14,9 @@ fst = "0.3.1"
14rustc-hash = "1.0" 14rustc-hash = "1.0"
15parking_lot = "0.7.0" 15parking_lot = "0.7.0"
16unicase = "2.2.0" 16unicase = "2.2.0"
17jemallocator = "0.1.9" 17
18jemalloc-ctl = "0.2.0" 18jemallocator = { version = "0.1.9", optional = true }
19jemalloc-ctl = { version = "0.2.0", optional = true }
19 20
20ra_syntax = { path = "../ra_syntax" } 21ra_syntax = { path = "../ra_syntax" }
21ra_ide_api_light = { path = "../ra_ide_api_light" } 22ra_ide_api_light = { path = "../ra_ide_api_light" }
@@ -26,3 +27,6 @@ test_utils = { path = "../test_utils" }
26 27
27[dev-dependencies] 28[dev-dependencies]
28insta = "0.5.1" 29insta = "0.5.1"
30
31[features]
32jemalloc = [ "jemallocator", "jemalloc-ctl" ]