aboutsummaryrefslogtreecommitdiff
path: root/crates/ra_ide_db/Cargo.toml
diff options
context:
space:
mode:
authorShotaro Yamada <[email protected]>2020-02-27 04:33:03 +0000
committerShotaro Yamada <[email protected]>2020-02-27 05:04:13 +0000
commit33de107ed94100ce61b4d326d6b4bcc22bb44ea8 (patch)
treeb15d0aae3efc94aa8087755e716ea4c2dbad12bf /crates/ra_ide_db/Cargo.toml
parent13e16a4ad4c32501472d6b1805ada19b62658135 (diff)
Remove unused dependencies
Diffstat (limited to 'crates/ra_ide_db/Cargo.toml')
-rw-r--r--crates/ra_ide_db/Cargo.toml12
1 files changed, 0 insertions, 12 deletions
diff --git a/crates/ra_ide_db/Cargo.toml b/crates/ra_ide_db/Cargo.toml
index 2f5b74b92..7b285d280 100644
--- a/crates/ra_ide_db/Cargo.toml
+++ b/crates/ra_ide_db/Cargo.toml
@@ -11,29 +11,17 @@ doctest = false
11wasm = [] 11wasm = []
12 12
13[dependencies] 13[dependencies]
14either = "1.5.3"
15format-buf = "1.0.0"
16indexmap = "1.3.2"
17itertools = "0.8.2"
18join_to_string = "0.1.3"
19log = "0.4.8" 14log = "0.4.8"
20rayon = "1.3.0" 15rayon = "1.3.0"
21fst = { version = "0.3.5", default-features = false } 16fst = { version = "0.3.5", default-features = false }
22rustc-hash = "1.1.0" 17rustc-hash = "1.1.0"
23superslice = "1.0.0" 18superslice = "1.0.0"
24once_cell = "1.3.1"
25 19
26ra_syntax = { path = "../ra_syntax" } 20ra_syntax = { path = "../ra_syntax" }
27ra_text_edit = { path = "../ra_text_edit" } 21ra_text_edit = { path = "../ra_text_edit" }
28ra_db = { path = "../ra_db" } 22ra_db = { path = "../ra_db" }
29ra_cfg = { path = "../ra_cfg" }
30ra_fmt = { path = "../ra_fmt" }
31ra_prof = { path = "../ra_prof" } 23ra_prof = { path = "../ra_prof" }
32test_utils = { path = "../test_utils" }
33 24
34# ra_ide should depend only on the top-level `hir` package. if you need 25# ra_ide should depend only on the top-level `hir` package. if you need
35# something from some `hir_xxx` subpackage, reexport the API via `hir`. 26# something from some `hir_xxx` subpackage, reexport the API via `hir`.
36hir = { path = "../ra_hir", package = "ra_hir" } 27hir = { path = "../ra_hir", package = "ra_hir" }
37
38[dev-dependencies]
39insta = "0.13.1"