aboutsummaryrefslogtreecommitdiff
path: root/crates/ra_ide_db/Cargo.toml
diff options
context:
space:
mode:
authorAleksey Kladov <[email protected]>2020-02-06 11:43:56 +0000
committerAleksey Kladov <[email protected]>2020-02-06 11:43:56 +0000
commit939f05f3e33e9f00d5205d60af3a862ae4d58bd6 (patch)
tree5de7e04d907c8e1cb0e101529abaad3d6f7beba3 /crates/ra_ide_db/Cargo.toml
parent1bfb111cf9ab938a8795f1ad2089cdd8b8c4b7a5 (diff)
Move to a crate
Diffstat (limited to 'crates/ra_ide_db/Cargo.toml')
-rw-r--r--crates/ra_ide_db/Cargo.toml48
1 files changed, 48 insertions, 0 deletions
diff --git a/crates/ra_ide_db/Cargo.toml b/crates/ra_ide_db/Cargo.toml
new file mode 100644
index 000000000..1b7905eb3
--- /dev/null
+++ b/crates/ra_ide_db/Cargo.toml
@@ -0,0 +1,48 @@
1[package]
2edition = "2018"
3name = "ra_ide_db"
4version = "0.1.0"
5authors = ["rust-analyzer developers"]
6
7[lib]
8doctest = false
9
10[features]
11wasm = []
12
13[dependencies]
14either = "1.5"
15format-buf = "1.0.0"
16indexmap = "1.3.0"
17itertools = "0.8.0"
18join_to_string = "0.1.3"
19log = "0.4.5"
20rayon = "1.0.2"
21fst = { version = "0.3.1", default-features = false }
22rustc-hash = "1.0"
23unicase = "2.2.0"
24superslice = "1.0.0"
25rand = { version = "0.7.0", features = ["small_rng"] }
26once_cell = "1.2.0"
27
28ra_syntax = { path = "../ra_syntax" }
29ra_text_edit = { path = "../ra_text_edit" }
30ra_db = { path = "../ra_db" }
31ra_cfg = { path = "../ra_cfg" }
32ra_fmt = { path = "../ra_fmt" }
33ra_prof = { path = "../ra_prof" }
34test_utils = { path = "../test_utils" }
35ra_assists = { path = "../ra_assists" }
36
37# ra_ide should depend only on the top-level `hir` package. if you need
38# something from some `hir_xxx` subpackage, reexport the API via `hir`.
39hir = { path = "../ra_hir", package = "ra_hir" }
40
41[dev-dependencies]
42insta = "0.13.0"
43
44[dev-dependencies.proptest]
45version = "0.9.0"
46# Disable `fork` feature to allow compiling on webassembly
47default-features = false
48features = ["std", "bit-set", "break-dead-code"]