diff options
author | Aleksey Kladov <[email protected]> | 2020-08-13 15:39:16 +0100 |
---|---|---|
committer | Aleksey Kladov <[email protected]> | 2020-08-13 15:39:16 +0100 |
commit | bb5c189b7dae1ea63ccd5d7a0c2e097d7c676f77 (patch) | |
tree | 62db93464dbd9ea154a8cb579a576202d97c01cc /crates/ra_ide_db/Cargo.toml | |
parent | ae71a631fd657368e8593feb5e025d23147afe60 (diff) |
Rename ra_ide_db -> ide_db
Diffstat (limited to 'crates/ra_ide_db/Cargo.toml')
-rw-r--r-- | crates/ra_ide_db/Cargo.toml | 32 |
1 files changed, 0 insertions, 32 deletions
diff --git a/crates/ra_ide_db/Cargo.toml b/crates/ra_ide_db/Cargo.toml deleted file mode 100644 index eda257a3a..000000000 --- a/crates/ra_ide_db/Cargo.toml +++ /dev/null | |||
@@ -1,32 +0,0 @@ | |||
1 | [package] | ||
2 | edition = "2018" | ||
3 | name = "ra_ide_db" | ||
4 | version = "0.1.0" | ||
5 | authors = ["rust-analyzer developers"] | ||
6 | license = "MIT OR Apache-2.0" | ||
7 | |||
8 | [lib] | ||
9 | doctest = false | ||
10 | |||
11 | [features] | ||
12 | wasm = [] | ||
13 | |||
14 | [dependencies] | ||
15 | log = "0.4.8" | ||
16 | rayon = "1.3.0" | ||
17 | fst = { version = "0.4", default-features = false } | ||
18 | rustc-hash = "1.1.0" | ||
19 | once_cell = "1.3.1" | ||
20 | either = "1.5.3" | ||
21 | |||
22 | stdx = { path = "../stdx" } | ||
23 | |||
24 | syntax = { path = "../syntax" } | ||
25 | text_edit = { path = "../text_edit" } | ||
26 | base_db = { path = "../base_db" } | ||
27 | profile = { path = "../profile" } | ||
28 | test_utils = { path = "../test_utils" } | ||
29 | |||
30 | # ra_ide should depend only on the top-level `hir` package. if you need | ||
31 | # something from some `hir_xxx` subpackage, reexport the API via `hir`. | ||
32 | hir = { path = "../hir" } | ||