aboutsummaryrefslogtreecommitdiff
path: root/crates/ra_ide_db/Cargo.toml
diff options
context:
space:
mode:
authorAleksey Kladov <[email protected]>2020-08-13 15:39:16 +0100
committerAleksey Kladov <[email protected]>2020-08-13 15:39:16 +0100
commitbb5c189b7dae1ea63ccd5d7a0c2e097d7c676f77 (patch)
tree62db93464dbd9ea154a8cb579a576202d97c01cc /crates/ra_ide_db/Cargo.toml
parentae71a631fd657368e8593feb5e025d23147afe60 (diff)
Rename ra_ide_db -> ide_db
Diffstat (limited to 'crates/ra_ide_db/Cargo.toml')
-rw-r--r--crates/ra_ide_db/Cargo.toml32
1 files changed, 0 insertions, 32 deletions
diff --git a/crates/ra_ide_db/Cargo.toml b/crates/ra_ide_db/Cargo.toml
deleted file mode 100644
index eda257a3a..000000000
--- a/crates/ra_ide_db/Cargo.toml
+++ /dev/null
@@ -1,32 +0,0 @@
1[package]
2edition = "2018"
3name = "ra_ide_db"
4version = "0.1.0"
5authors = ["rust-analyzer developers"]
6license = "MIT OR Apache-2.0"
7
8[lib]
9doctest = false
10
11[features]
12wasm = []
13
14[dependencies]
15log = "0.4.8"
16rayon = "1.3.0"
17fst = { version = "0.4", default-features = false }
18rustc-hash = "1.1.0"
19once_cell = "1.3.1"
20either = "1.5.3"
21
22stdx = { path = "../stdx" }
23
24syntax = { path = "../syntax" }
25text_edit = { path = "../text_edit" }
26base_db = { path = "../base_db" }
27profile = { path = "../profile" }
28test_utils = { path = "../test_utils" }
29
30# ra_ide should depend only on the top-level `hir` package. if you need
31# something from some `hir_xxx` subpackage, reexport the API via `hir`.
32hir = { path = "../hir" }