diff options
author | bors[bot] <26634292+bors[bot]@users.noreply.github.com> | 2020-02-06 14:14:47 +0000 |
---|---|---|
committer | GitHub <[email protected]> | 2020-02-06 14:14:47 +0000 |
commit | ff2d77bde6acffc5e4c42878606b3d6d92300e11 (patch) | |
tree | 76b0a8bbf94b0c68dd3aa891e0d9ea5cdf067863 /crates/ra_ide_db/Cargo.toml | |
parent | 19de59a9233a09a9b70a96a6c49213b119819c46 (diff) | |
parent | 355c98fd0861acf0f0fddad08cbc923fee0698fb (diff) |
Merge #3029
3029: Docs r=matklad a=matklad
Co-authored-by: Aleksey Kladov <[email protected]>
Diffstat (limited to 'crates/ra_ide_db/Cargo.toml')
-rw-r--r-- | crates/ra_ide_db/Cargo.toml | 48 |
1 files changed, 48 insertions, 0 deletions
diff --git a/crates/ra_ide_db/Cargo.toml b/crates/ra_ide_db/Cargo.toml new file mode 100644 index 000000000..1b7905eb3 --- /dev/null +++ b/crates/ra_ide_db/Cargo.toml | |||
@@ -0,0 +1,48 @@ | |||
1 | [package] | ||
2 | edition = "2018" | ||
3 | name = "ra_ide_db" | ||
4 | version = "0.1.0" | ||
5 | authors = ["rust-analyzer developers"] | ||
6 | |||
7 | [lib] | ||
8 | doctest = false | ||
9 | |||
10 | [features] | ||
11 | wasm = [] | ||
12 | |||
13 | [dependencies] | ||
14 | either = "1.5" | ||
15 | format-buf = "1.0.0" | ||
16 | indexmap = "1.3.0" | ||
17 | itertools = "0.8.0" | ||
18 | join_to_string = "0.1.3" | ||
19 | log = "0.4.5" | ||
20 | rayon = "1.0.2" | ||
21 | fst = { version = "0.3.1", default-features = false } | ||
22 | rustc-hash = "1.0" | ||
23 | unicase = "2.2.0" | ||
24 | superslice = "1.0.0" | ||
25 | rand = { version = "0.7.0", features = ["small_rng"] } | ||
26 | once_cell = "1.2.0" | ||
27 | |||
28 | ra_syntax = { path = "../ra_syntax" } | ||
29 | ra_text_edit = { path = "../ra_text_edit" } | ||
30 | ra_db = { path = "../ra_db" } | ||
31 | ra_cfg = { path = "../ra_cfg" } | ||
32 | ra_fmt = { path = "../ra_fmt" } | ||
33 | ra_prof = { path = "../ra_prof" } | ||
34 | test_utils = { path = "../test_utils" } | ||
35 | ra_assists = { path = "../ra_assists" } | ||
36 | |||
37 | # ra_ide should depend only on the top-level `hir` package. if you need | ||
38 | # something from some `hir_xxx` subpackage, reexport the API via `hir`. | ||
39 | hir = { path = "../ra_hir", package = "ra_hir" } | ||
40 | |||
41 | [dev-dependencies] | ||
42 | insta = "0.13.0" | ||
43 | |||
44 | [dev-dependencies.proptest] | ||
45 | version = "0.9.0" | ||
46 | # Disable `fork` feature to allow compiling on webassembly | ||
47 | default-features = false | ||
48 | features = ["std", "bit-set", "break-dead-code"] | ||