aboutsummaryrefslogtreecommitdiff
path: root/crates/ra_lsp_server/Cargo.toml
diff options
context:
space:
mode:
authorbors[bot] <bors[bot]@users.noreply.github.com>2018-12-28 07:11:54 +0000
committerbors[bot] <bors[bot]@users.noreply.github.com>2018-12-28 07:11:54 +0000
commit161054a616835ff5eebbc6692c8795c049b8b0d7 (patch)
tree6f649cf640bd5b5855310dec4c3ab6f470c60d96 /crates/ra_lsp_server/Cargo.toml
parente80021cbd0bcfea82f3b855e13a409c73b563673 (diff)
parent626badc30a5a5584e24f9401b163799772288079 (diff)
Merge #349
349: Bump serde from 1.0.82 to 1.0.83 r=matklad a=dependabot[bot] Bumps [serde](https://github.com/serde-rs/serde) from 1.0.82 to 1.0.83. <details> <summary>Release notes</summary> *Sourced from [serde's releases](https://github.com/serde-rs/serde/releases).* > ## v1.0.83 > - Support a `rename_all` specification that applies only to the Serialize impl or only to the Deserialize impl ([#1447](https://github-redirect.dependabot.com/serde-rs/serde/issues/1447), thanks [**vincascm**](https://github.com/vincascm)) > > ```rust > #[derive(Serialize, Deserialize)] > #[serde(rename_all( > serialize = "camelCase", > deserialize = "SCREAMING_SNAKE_CASE", > ))] > struct S { /* ... */ } > ``` > > - Allow serializing struct name inside of structs with named fields ([#1448](https://github-redirect.dependabot.com/serde-rs/serde/issues/1448), thanks [**motu42**](https://github.com/motu42)) > > ```rust > #[derive(Serialize)] > #[serde(tag = "type")] > struct S { /* ... */ } // serializes as {"type":"S",...} > ``` </details> <details> <summary>Commits</summary> - [`b1b9702`](https://github.com/serde-rs/serde/commit/b1b9702dafc41651b5736cb9ebad1f6389599300) Release 1.0.83 - [`32728d2`](https://github.com/serde-rs/serde/commit/32728d2f1def957605200be1ccf35b27bbe59e87) Format with rustfmt 2018-12-10 - [`807a097`](https://github.com/serde-rs/serde/commit/807a097387abe3db52b682232d714c5d31d97fb4) Fix spelling in ui test name - [`794ee15`](https://github.com/serde-rs/serde/commit/794ee15386b07c6df55165a98499d743df2b804b) Merge pull request [#1448](https://github-redirect.dependabot.com/serde-rs/serde/issues/1448) from motu42/master - [`2359417`](https://github.com/serde-rs/serde/commit/23594178040cb4cce46fedcbd149641955542652) Added ui tests, Limited serde(tag = "...") to structs with named field - [`7950f3c`](https://github.com/serde-rs/serde/commit/7950f3cdc52d4898aa4195b853cbec12d65bb091) Format with rustfmt 2018-12-10 - [`b87f8f3`](https://github.com/serde-rs/serde/commit/b87f8f35ee631ff5fb8f01e0ebf5ad1f5148d369) Merge pull request 1447 from vincascm/master - [`9e53405`](https://github.com/serde-rs/serde/commit/9e53405f43ad0e087dea7ed64ddafca0356c6560) Fix for rustc 1.15.0 - [`c6c1d8f`](https://github.com/serde-rs/serde/commit/c6c1d8fa869774afd32dc5250bb32f641f03cbba) Work around deprecation of str::trim_left_matches - [`8aa5c2b`](https://github.com/serde-rs/serde/commit/8aa5c2b45dcebd5222593a97f3b50fa11212a74c) Removed deprected ui/enum-representation/internally-tagged-struct test - Additional commits viewable in [compare view](https://github.com/serde-rs/serde/compare/v1.0.82...v1.0.83) </details> <br /> [![Dependabot compatibility score](https://api.dependabot.com/badges/compatibility_score?dependency-name=serde&package-manager=cargo&previous-version=1.0.82&new-version=1.0.83)](https://dependabot.com/compatibility-score.html?dependency-name=serde&package-manager=cargo&previous-version=1.0.82&new-version=1.0.83) Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting `@dependabot rebase`. [//]: # (dependabot-automerge-start) [//]: # (dependabot-automerge-end) --- **Note:** This repo was added to Dependabot recently, so you'll receive a maximum of 5 PRs for your first few update runs. Once an update run creates fewer than 5 PRs we'll remove that limit. You can always request more updates by clicking `Bump now` in your [Dependabot dashboard](https://app.dependabot.com). <details> <summary>Dependabot commands and options</summary> <br /> You can trigger Dependabot actions by commenting on this PR: - `@dependabot rebase` will rebase this PR - `@dependabot recreate` will recreate this PR, overwriting any edits that have been made to it - `@dependabot merge` will merge this PR after your CI passes on it - `@dependabot cancel merge` will cancel a previously requested merge - `@dependabot reopen` will reopen this PR if it is closed - `@dependabot ignore this [patch|minor|major] version` will close this PR and stop Dependabot creating any more for this minor/major version (unless you reopen the PR or upgrade to it yourself) - `@dependabot ignore this dependency` will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself) - `@dependabot use these labels` will set the current labels as the default for future PRs for this repo and language - `@dependabot use these reviewers` will set the current reviewers as the default for future PRs for this repo and language - `@dependabot use these assignees` will set the current assignees as the default for future PRs for this repo and language - `@dependabot use this milestone` will set the current milestone as the default for future PRs for this repo and language - `@dependabot badge me` will comment on this PR with code to add a "Dependabot enabled" badge to your readme Additionally, you can set the following in your Dependabot [dashboard](https://app.dependabot.com): - Update frequency (including time of day and day of week) - Automerge options (never/patch/minor, and dev/runtime dependencies) - Pull request limits (per update run and/or open at any time) - Out-of-range updates (receive only lockfile updates, if desired) - Security updates (receive only security updates, if desired) Finally, you can contact us by mentioning @dependabot. </details> Co-authored-by: dependabot[bot] <[email protected]>
Diffstat (limited to 'crates/ra_lsp_server/Cargo.toml')
-rw-r--r--crates/ra_lsp_server/Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/crates/ra_lsp_server/Cargo.toml b/crates/ra_lsp_server/Cargo.toml
index 78c06c7f7..c53106a62 100644
--- a/crates/ra_lsp_server/Cargo.toml
+++ b/crates/ra_lsp_server/Cargo.toml
@@ -11,7 +11,7 @@ relative-path = "0.4.0"
11failure = "0.1.2" 11failure = "0.1.2"
12failure_derive = "0.1.2" 12failure_derive = "0.1.2"
13serde_json = "1.0.24" 13serde_json = "1.0.24"
14serde = "1.0.71" 14serde = "1.0.83"
15drop_bomb = "0.1.0" 15drop_bomb = "0.1.0"
16crossbeam-channel = "0.2.4" 16crossbeam-channel = "0.2.4"
17flexi_logger = "0.10.0" 17flexi_logger = "0.10.0"