aboutsummaryrefslogtreecommitdiff
path: root/crates/ra_lsp_server/Cargo.toml
diff options
context:
space:
mode:
authorbors[bot] <26634292+bors[bot]@users.noreply.github.com>2019-09-06 15:22:00 +0100
committerGitHub <[email protected]>2019-09-06 15:22:00 +0100
commit1acd9d5540bf755e87173fe16a803cfe8b2bb500 (patch)
treea5fb9afa541a4e6ab5818530b3fd19d5e461ef9e /crates/ra_lsp_server/Cargo.toml
parent007737a0e7dd2866e02a6398d8ee4aa7d5051d8c (diff)
parent28df377759ee5625b0dad4c797be306c8d2624e3 (diff)
Merge #1780
1780: add option to disable notify r=matklad a=matklad This should help if notify uses 100% of CPU. Put ``` { "rust-analyzer.useClientWatching": true, } ``` into `.vscode/settings.json` (or appropriate config of your editor) to use editor's file watching capabilites instead of notify Co-authored-by: Aleksey Kladov <[email protected]>
Diffstat (limited to 'crates/ra_lsp_server/Cargo.toml')
-rw-r--r--crates/ra_lsp_server/Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/crates/ra_lsp_server/Cargo.toml b/crates/ra_lsp_server/Cargo.toml
index 07cc2dd32..46a0f958c 100644
--- a/crates/ra_lsp_server/Cargo.toml
+++ b/crates/ra_lsp_server/Cargo.toml
@@ -16,7 +16,7 @@ lsp-types = { version = "0.61.0", features = ["proposed"] }
16rustc-hash = "1.0" 16rustc-hash = "1.0"
17parking_lot = "0.9.0" 17parking_lot = "0.9.0"
18jod-thread = "0.1.0" 18jod-thread = "0.1.0"
19ra_vfs = "0.3.0" 19ra_vfs = "0.4.0"
20ra_syntax = { path = "../ra_syntax" } 20ra_syntax = { path = "../ra_syntax" }
21ra_text_edit = { path = "../ra_text_edit" } 21ra_text_edit = { path = "../ra_text_edit" }
22ra_ide_api = { path = "../ra_ide_api" } 22ra_ide_api = { path = "../ra_ide_api" }