aboutsummaryrefslogtreecommitdiff
path: root/crates/ra_lsp_server/Cargo.toml
diff options
context:
space:
mode:
authorbors[bot] <26634292+bors[bot]@users.noreply.github.com>2019-11-30 19:19:28 +0000
committerGitHub <[email protected]>2019-11-30 19:19:28 +0000
commit780f476b4f438d473bc2e2299c2b8bf0a6fb9257 (patch)
treede3a3eceb92c9604bc14c12885ce887186c39dd3 /crates/ra_lsp_server/Cargo.toml
parent9712889ee4c6cffa37c2ace5da9b00bf29adab56 (diff)
parent3fe539ce51f417605a6da6bc3c6d135053b1ee67 (diff)
Merge #2451
2451: Use env_logger instead of flexi_logger r=matklad a=AlexanderEkdahl This fixes https://github.com/rust-analyzer/rust-analyzer/issues/2335 - By default only `error` will be printed. From what I can tell this matches the current behaviour. Configured through `RUST_LOG`. - I looked through the optional dependencies for `env_logger`and I have only enabled `human_time`. Without this feature no timestamp will be shown for log messages. - `RA_LOG_DIR` feature is removed This PR adds 2 new dependencies(`env_logger` and `human_time`) and removes 6 dependencies. Co-authored-by: Alexander Ekdahl <[email protected]>
Diffstat (limited to 'crates/ra_lsp_server/Cargo.toml')
-rw-r--r--crates/ra_lsp_server/Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/crates/ra_lsp_server/Cargo.toml b/crates/ra_lsp_server/Cargo.toml
index 21aef842c..41672eaff 100644
--- a/crates/ra_lsp_server/Cargo.toml
+++ b/crates/ra_lsp_server/Cargo.toml
@@ -13,7 +13,6 @@ relative-path = "1.0.0"
13serde_json = "1.0.34" 13serde_json = "1.0.34"
14serde = { version = "1.0.83", features = ["derive"] } 14serde = { version = "1.0.83", features = ["derive"] }
15crossbeam-channel = "0.4" 15crossbeam-channel = "0.4"
16flexi_logger = "0.14.0"
17log = "0.4.3" 16log = "0.4.3"
18lsp-types = { version = "0.61.0", features = ["proposed"] } 17lsp-types = { version = "0.61.0", features = ["proposed"] }
19rustc-hash = "1.0" 18rustc-hash = "1.0"
@@ -27,6 +26,7 @@ lsp-server = "0.3.0"
27ra_project_model = { path = "../ra_project_model" } 26ra_project_model = { path = "../ra_project_model" }
28ra_prof = { path = "../ra_prof" } 27ra_prof = { path = "../ra_prof" }
29ra_vfs_glob = { path = "../ra_vfs_glob" } 28ra_vfs_glob = { path = "../ra_vfs_glob" }
29env_logger = { version = "0.7.1", default-features = false, features = ["humantime"] }
30 30
31[dev-dependencies] 31[dev-dependencies]
32tempfile = "3" 32tempfile = "3"