aboutsummaryrefslogtreecommitdiff
path: root/crates/ra_lsp_server/Cargo.toml
diff options
context:
space:
mode:
authorAleksey Kladov <[email protected]>2018-12-19 12:04:15 +0000
committerAleksey Kladov <[email protected]>2018-12-20 09:15:38 +0000
commita5ef8ad05b7c1f7148c59814b55d641fd75aff75 (patch)
treedf6c46378d81dc7cb3242ff7f57d836353bde5ed /crates/ra_lsp_server/Cargo.toml
parent6a755ed83a583d1f70a5fbcff2d4933b52628cfe (diff)
swtich lsp server to vfs
Diffstat (limited to 'crates/ra_lsp_server/Cargo.toml')
-rw-r--r--crates/ra_lsp_server/Cargo.toml2
1 files changed, 2 insertions, 0 deletions
diff --git a/crates/ra_lsp_server/Cargo.toml b/crates/ra_lsp_server/Cargo.toml
index 4e8e09584..fc10096e5 100644
--- a/crates/ra_lsp_server/Cargo.toml
+++ b/crates/ra_lsp_server/Cargo.toml
@@ -25,6 +25,7 @@ cargo_metadata = "0.6.0"
25text_unit = { version = "0.1.2", features = ["serde"] } 25text_unit = { version = "0.1.2", features = ["serde"] }
26smol_str = { version = "0.1.5", features = ["serde"] } 26smol_str = { version = "0.1.5", features = ["serde"] }
27rustc-hash = "1.0" 27rustc-hash = "1.0"
28parking_lot = "0.7.0"
28 29
29thread_worker = { path = "../thread_worker" } 30thread_worker = { path = "../thread_worker" }
30ra_syntax = { path = "../ra_syntax" } 31ra_syntax = { path = "../ra_syntax" }
@@ -32,6 +33,7 @@ ra_editor = { path = "../ra_editor" }
32ra_text_edit = { path = "../ra_text_edit" } 33ra_text_edit = { path = "../ra_text_edit" }
33ra_analysis = { path = "../ra_analysis" } 34ra_analysis = { path = "../ra_analysis" }
34gen_lsp_server = { path = "../gen_lsp_server" } 35gen_lsp_server = { path = "../gen_lsp_server" }
36ra_vfs = { path = "../ra_vfs" }
35 37
36[dev-dependencies] 38[dev-dependencies]
37tempdir = "0.3.7" 39tempdir = "0.3.7"