aboutsummaryrefslogtreecommitdiff
path: root/crates/ra_lsp_server/Cargo.toml
diff options
context:
space:
mode:
authorAleksey Kladov <[email protected]>2020-02-18 12:30:40 +0000
committerGitHub <[email protected]>2020-02-18 12:30:40 +0000
commitd05480a178b132e62b8aff8986a8cb3dd3a89c0b (patch)
tree0fc36373073a66c2bbd6c7cfae6cb734527d847f /crates/ra_lsp_server/Cargo.toml
parent2768476e491d985317b08230824f96e6718f338a (diff)
parent865759925be6b72f7ef39124ed0e4c86c0412a69 (diff)
Merge pull request #3216 from matklad/rename-to-rust-analyzer
rename binary to rust-analyzer
Diffstat (limited to 'crates/ra_lsp_server/Cargo.toml')
-rw-r--r--crates/ra_lsp_server/Cargo.toml58
1 files changed, 0 insertions, 58 deletions
diff --git a/crates/ra_lsp_server/Cargo.toml b/crates/ra_lsp_server/Cargo.toml
deleted file mode 100644
index 151ca3da5..000000000
--- a/crates/ra_lsp_server/Cargo.toml
+++ /dev/null
@@ -1,58 +0,0 @@
1[package]
2edition = "2018"
3name = "ra_lsp_server"
4version = "0.1.0"
5authors = ["rust-analyzer developers"]
6autobins = false
7
8[lib]
9doctest = false
10
11[[bin]]
12name = "ra_lsp_server"
13path = "./src/bin/main.rs"
14
15[dependencies]
16anyhow = "1.0"
17crossbeam-channel = "0.4"
18either = "1.5"
19env_logger = { version = "0.7.1", default-features = false }
20globset = "0.4.4"
21itertools = "0.8.0"
22jod-thread = "0.1.0"
23log = "0.4.3"
24lsp-types = { version = "0.70.0", features = ["proposed"] }
25parking_lot = "0.10.0"
26pico-args = "0.3.0"
27rand = { version = "0.7.0", features = ["small_rng"] }
28relative-path = "1.0.0"
29rustc-hash = "1.0"
30serde = { version = "1.0.83", features = ["derive"] }
31serde_json = "1.0.34"
32threadpool = "1.7.1"
33
34lsp-server = "0.3.0"
35ra_cargo_watch = { path = "../ra_cargo_watch" }
36ra_ide = { path = "../ra_ide" }
37ra_prof = { path = "../ra_prof" }
38ra_project_model = { path = "../ra_project_model" }
39ra_syntax = { path = "../ra_syntax" }
40ra_text_edit = { path = "../ra_text_edit" }
41ra_vfs = "0.5.0"
42
43# This should only be used in CLI
44ra_db = { path = "../ra_db" }
45hir = { path = "../ra_hir", package = "ra_hir" }
46hir_def = { path = "../ra_hir_def", package = "ra_hir_def" }
47hir_ty = { path = "../ra_hir_ty", package = "ra_hir_ty" }
48
49
50[target.'cfg(windows)'.dependencies]
51winapi = "0.3"
52
53[dev-dependencies]
54tempfile = "3"
55test_utils = { path = "../test_utils" }
56
57[features]
58jemalloc = [ "ra_prof/jemalloc" ]