diff options
author | bors[bot] <26634292+bors[bot]@users.noreply.github.com> | 2020-02-18 14:37:34 +0000 |
---|---|---|
committer | GitHub <[email protected]> | 2020-02-18 14:37:34 +0000 |
commit | cecf25b72f2af84fc1535cf52d6f3c1b52802565 (patch) | |
tree | 37c8dde0a459caacae6629da08d86be270469ef5 /crates/ra_mbe/Cargo.toml | |
parent | eab80cd961919b9321e1d34343ae3f3adb0502e5 (diff) | |
parent | f6816c253b96e8436f1156d6bd6b0942ee9fb4d3 (diff) |
Merge #3220
3220: Fix clippy warnings, update Cargo.toml versions r=matklad a=SomeoneToIgnore
In the `cargo xtask lint` ouptut, there were two interesting Clippy warnings that might be interesting to investigate further:
* warning: this argument (4 byte) is passed by reference, but would be more efficient if passed by value (limit: 8 byte)
* warning: large size difference between variants
Co-authored-by: Kirill Bulatov <[email protected]>
Diffstat (limited to 'crates/ra_mbe/Cargo.toml')
-rw-r--r-- | crates/ra_mbe/Cargo.toml | 6 |
1 files changed, 3 insertions, 3 deletions
diff --git a/crates/ra_mbe/Cargo.toml b/crates/ra_mbe/Cargo.toml index a3fc01f63..4dec24914 100644 --- a/crates/ra_mbe/Cargo.toml +++ b/crates/ra_mbe/Cargo.toml | |||
@@ -11,9 +11,9 @@ doctest = false | |||
11 | ra_syntax = { path = "../ra_syntax" } | 11 | ra_syntax = { path = "../ra_syntax" } |
12 | ra_parser = { path = "../ra_parser" } | 12 | ra_parser = { path = "../ra_parser" } |
13 | tt = { path = "../ra_tt", package = "ra_tt" } | 13 | tt = { path = "../ra_tt", package = "ra_tt" } |
14 | rustc-hash = "1.0.0" | 14 | rustc-hash = "1.1.0" |
15 | smallvec = "1.0.0" | 15 | smallvec = "1.2.0" |
16 | log = "0.4.5" | 16 | log = "0.4.8" |
17 | 17 | ||
18 | [dev-dependencies] | 18 | [dev-dependencies] |
19 | test_utils = { path = "../test_utils" } | 19 | test_utils = { path = "../test_utils" } |