aboutsummaryrefslogtreecommitdiff
path: root/crates/ra_proc_macro/Cargo.toml
diff options
context:
space:
mode:
authorbors[bot] <26634292+bors[bot]@users.noreply.github.com>2020-03-31 15:30:24 +0100
committerGitHub <[email protected]>2020-03-31 15:30:24 +0100
commit7a546490ecb93b9da1cd888086f00a69ebd8d0aa (patch)
tree18c25777f7f0fad8f60f58bf7187db45fe3307fd /crates/ra_proc_macro/Cargo.toml
parentfa3c7742af9fbfe5146f4158a6119fa727dcc87a (diff)
parent207903a1c33961c2014010f5678b1c6807e7f6d6 (diff)
Merge #3738
3738: Implement ra_proc_macro client logic r=matklad a=edwin0cheng This PR add the actual client logic for `ra_proc_macro` crate: 1. Define all necessary rpc serialization data structure, which include `ra_tt` related data and some task messages. Although adding `Serialize` and `Deserialize` trait to ra_tt directly seem to be much easier, we deliberately duplicate the `ra_tt` struct with `#[serde(with = "XXDef")]` for separation of code responsibility. 2. Define a simplified version of lsp base protocol for rpc, which basically copy from lsp-server code base. 3. Implement the actual `IO` for the client side progress spawning and message passing. Co-authored-by: Edwin Cheng <[email protected]>
Diffstat (limited to 'crates/ra_proc_macro/Cargo.toml')
-rw-r--r--crates/ra_proc_macro/Cargo.toml5
1 files changed, 5 insertions, 0 deletions
diff --git a/crates/ra_proc_macro/Cargo.toml b/crates/ra_proc_macro/Cargo.toml
index bc2c37296..d009ceb82 100644
--- a/crates/ra_proc_macro/Cargo.toml
+++ b/crates/ra_proc_macro/Cargo.toml
@@ -10,3 +10,8 @@ doctest = false
10 10
11[dependencies] 11[dependencies]
12ra_tt = { path = "../ra_tt" } 12ra_tt = { path = "../ra_tt" }
13serde = { version = "1.0", features = ["derive"] }
14serde_json = "1.0"
15log = "0.4.8"
16crossbeam-channel = "0.4.0"
17jod-thread = "0.1.1"