aboutsummaryrefslogtreecommitdiff
path: root/crates/ra_proc_macro_srv/Cargo.toml
diff options
context:
space:
mode:
authorbors[bot] <26634292+bors[bot]@users.noreply.github.com>2020-04-03 13:06:04 +0100
committerGitHub <[email protected]>2020-04-03 13:06:04 +0100
commit1a8779bce07281f1fbde1166ded75bc5acaa0f27 (patch)
tree3c69ce23117592f5442bcfdfc165820394b775a3 /crates/ra_proc_macro_srv/Cargo.toml
parentac91de1525662a602a1057709eb91a9b21ea3ac7 (diff)
parent9a2114b0dd6d3292216fa4d05e3c4cd219633f4b (diff)
Merge #3800
3800: Introduce ra_proc_macro_srv r=matklad a=edwin0cheng This PR add preliminary for server side of proc macro : 1. Add crate setup 2. IO for server side Co-authored-by: Edwin Cheng <[email protected]>
Diffstat (limited to 'crates/ra_proc_macro_srv/Cargo.toml')
-rw-r--r--crates/ra_proc_macro_srv/Cargo.toml24
1 files changed, 24 insertions, 0 deletions
diff --git a/crates/ra_proc_macro_srv/Cargo.toml b/crates/ra_proc_macro_srv/Cargo.toml
new file mode 100644
index 000000000..fa2de2c91
--- /dev/null
+++ b/crates/ra_proc_macro_srv/Cargo.toml
@@ -0,0 +1,24 @@
1[package]
2edition = "2018"
3name = "ra_proc_macro_srv"
4version = "0.1.0"
5authors = ["rust-analyzer developers"]
6publish = false
7
8[lib]
9doctest = false
10
11[dependencies]
12ra_tt = { path = "../ra_tt" }
13ra_mbe = { path = "../ra_mbe" }
14ra_proc_macro = { path = "../ra_proc_macro" }
15
16serde_derive = "1.0.104"
17serde = "1.0.104"
18serde_json = "1.0.48"
19libloading = "0.5.2"
20goblin = "0.2.0"
21
22[dev-dependencies]
23cargo_metadata = "0.9.1"
24difference = "2.0.0"