aboutsummaryrefslogtreecommitdiff
path: root/crates/ra_proc_macro_srv/Cargo.toml
diff options
context:
space:
mode:
authorbors[bot] <26634292+bors[bot]@users.noreply.github.com>2020-04-06 16:08:26 +0100
committerGitHub <[email protected]>2020-04-06 16:08:26 +0100
commitf6d688d13070a54b288486900a30680d013c66ca (patch)
tree39262a1e6cb34897723c4c36b7503fc1483c5a9f /crates/ra_proc_macro_srv/Cargo.toml
parent2603a9e628d304c8cb8fd08979e2f9c9afeac69e (diff)
parent4f70162f54ceaa4ff68a5ab74e31b5dda7ac9444 (diff)
Merge #3842
3842: Add lib-proc-macro mod in ra_proc_macro_srv r=matklad a=edwin0cheng This PR add a module in ra_proc_macro_srv, which is just copy & paste from rustc lib_proc_macro and remove all unstable features in it. The main idea here is by doing that, we could build the `ra_proc_macro_srv` without nightly compiler and remain ABI compatibility. Co-authored-by: Edwin Cheng <[email protected]>
Diffstat (limited to 'crates/ra_proc_macro_srv/Cargo.toml')
-rw-r--r--crates/ra_proc_macro_srv/Cargo.toml5
1 files changed, 2 insertions, 3 deletions
diff --git a/crates/ra_proc_macro_srv/Cargo.toml b/crates/ra_proc_macro_srv/Cargo.toml
index 315191cc5..6300d668a 100644
--- a/crates/ra_proc_macro_srv/Cargo.toml
+++ b/crates/ra_proc_macro_srv/Cargo.toml
@@ -12,10 +12,9 @@ doctest = false
12ra_tt = { path = "../ra_tt" } 12ra_tt = { path = "../ra_tt" }
13ra_proc_macro = { path = "../ra_proc_macro" } 13ra_proc_macro = { path = "../ra_proc_macro" }
14 14
15serde_derive = "1.0.104"
16serde = "1.0.104"
17serde_json = "1.0.48"
18 15
19[dev-dependencies] 16[dev-dependencies]
20cargo_metadata = "0.9.1" 17cargo_metadata = "0.9.1"
21difference = "2.0.0" 18difference = "2.0.0"
19# used as proc macro test target
20serde_derive = "=1.0.104" \ No newline at end of file