aboutsummaryrefslogtreecommitdiff
path: root/crates/ra_prof/Cargo.toml
diff options
context:
space:
mode:
authorbors[bot] <26634292+bors[bot]@users.noreply.github.com>2019-06-30 11:42:23 +0100
committerbors[bot] <26634292+bors[bot]@users.noreply.github.com>2019-06-30 11:42:23 +0100
commit2ad8220f58675193860337a00fed87162a98dc1a (patch)
treee39c335b575481fb40b183c82db25a222076c96b /crates/ra_prof/Cargo.toml
parentbb70d18a0a51a2321780e8eaa0262ec61a659b05 (diff)
parent18a1e092e9406c6670cd38d17997325bba7bbfdc (diff)
Merge #1462
1462: Move memory usage statistics to ra_prof r=matklad a=matklad Co-authored-by: Aleksey Kladov <[email protected]>
Diffstat (limited to 'crates/ra_prof/Cargo.toml')
-rw-r--r--crates/ra_prof/Cargo.toml6
1 files changed, 6 insertions, 0 deletions
diff --git a/crates/ra_prof/Cargo.toml b/crates/ra_prof/Cargo.toml
index 787e18385..e986019ca 100644
--- a/crates/ra_prof/Cargo.toml
+++ b/crates/ra_prof/Cargo.toml
@@ -10,3 +10,9 @@ once_cell = "0.2.0"
10itertools = "0.8.0" 10itertools = "0.8.0"
11backtrace = "0.3.28" 11backtrace = "0.3.28"
12cpuprofiler = { version = "0.0.3", optional = true } 12cpuprofiler = { version = "0.0.3", optional = true }
13jemallocator = { version = "0.1.9", optional = true }
14jemalloc-ctl = { version = "0.2.0", optional = true }
15
16
17[features]
18jemalloc = [ "jemallocator", "jemalloc-ctl" ]