aboutsummaryrefslogtreecommitdiff
path: root/crates/ra_prof/Cargo.toml
diff options
context:
space:
mode:
authorJonas Schievink <[email protected]>2020-07-21 18:30:17 +0100
committerJonas Schievink <[email protected]>2020-07-21 18:55:54 +0100
commit56c090d0d0ad68c0dd195684e4d8180ea149692f (patch)
tree15bf2a269ff33efb86b4769b799ba9559ce60b66 /crates/ra_prof/Cargo.toml
parenta3ff2751b4cf8625e2874a482fe4d58da3d02891 (diff)
Allow gathering memory stats on non-jemalloc Linux
Diffstat (limited to 'crates/ra_prof/Cargo.toml')
-rw-r--r--crates/ra_prof/Cargo.toml2
1 files changed, 2 insertions, 0 deletions
diff --git a/crates/ra_prof/Cargo.toml b/crates/ra_prof/Cargo.toml
index b3d52985a..2e60858f1 100644
--- a/crates/ra_prof/Cargo.toml
+++ b/crates/ra_prof/Cargo.toml
@@ -14,6 +14,8 @@ ra_arena = { path = "../ra_arena" }
14once_cell = "1.3.1" 14once_cell = "1.3.1"
15backtrace = { version = "0.3.44", optional = true } 15backtrace = { version = "0.3.44", optional = true }
16mimalloc = { version = "0.1.19", default-features = false, optional = true } 16mimalloc = { version = "0.1.19", default-features = false, optional = true }
17cfg-if = "0.1.10"
18libc = "0.2.73"
17 19
18[target.'cfg(not(target_env = "msvc"))'.dependencies] 20[target.'cfg(not(target_env = "msvc"))'.dependencies]
19jemallocator = { version = "0.3.2", optional = true } 21jemallocator = { version = "0.3.2", optional = true }