aboutsummaryrefslogtreecommitdiff
path: root/crates/ra_prof/Cargo.toml
diff options
context:
space:
mode:
authorIvan Kozik <[email protected]>2020-07-14 01:12:49 +0100
committerIvan Kozik <[email protected]>2020-07-14 21:57:51 +0100
commit6710856c1098f71168c47451af53bac9a33b49dd (patch)
tree46a514e5fd86dd33f16f9abca6ab14f5063c9696 /crates/ra_prof/Cargo.toml
parent46d4487b8900324fc6a523c8b6ebe036d28fd0fb (diff)
Add opt-in mimalloc feature
Diffstat (limited to 'crates/ra_prof/Cargo.toml')
-rw-r--r--crates/ra_prof/Cargo.toml2
1 files changed, 2 insertions, 0 deletions
diff --git a/crates/ra_prof/Cargo.toml b/crates/ra_prof/Cargo.toml
index eabfcebb0..3cd8481ea 100644
--- a/crates/ra_prof/Cargo.toml
+++ b/crates/ra_prof/Cargo.toml
@@ -12,6 +12,7 @@ doctest = false
12ra_arena = { path = "../ra_arena" } 12ra_arena = { path = "../ra_arena" }
13once_cell = "1.3.1" 13once_cell = "1.3.1"
14backtrace = { version = "0.3.44", optional = true } 14backtrace = { version = "0.3.44", optional = true }
15mimalloc = { version = "0.1.19", default-features = false, optional = true }
15 16
16[target.'cfg(not(target_env = "msvc"))'.dependencies] 17[target.'cfg(not(target_env = "msvc"))'.dependencies]
17jemallocator = { version = "0.3.2", optional = true } 18jemallocator = { version = "0.3.2", optional = true }
@@ -24,4 +25,5 @@ cpu_profiler = []
24# Uncomment to enable for the whole crate graph 25# Uncomment to enable for the whole crate graph
25# default = [ "backtrace" ] 26# default = [ "backtrace" ]
26# default = [ "jemalloc" ] 27# default = [ "jemalloc" ]
28# default = [ "mimalloc" ]
27# default = [ "cpu_profiler" ] 29# default = [ "cpu_profiler" ]