aboutsummaryrefslogtreecommitdiff
path: root/crates/ra_project_model/Cargo.toml
diff options
context:
space:
mode:
authorFlorian Diebold <[email protected]>2019-02-05 22:10:49 +0000
committerFlorian Diebold <[email protected]>2019-02-09 10:15:25 +0000
commitfcd615e4b76264b4fff7b5be454787bb6a4252ea (patch)
tree112d17480bd065551a9d18c21ab51326f3e3a295 /crates/ra_project_model/Cargo.toml
parent34398a8756b56c323d3b4b2ef32fbca32d88a105 (diff)
Extract project model to separate crate
Diffstat (limited to 'crates/ra_project_model/Cargo.toml')
-rw-r--r--crates/ra_project_model/Cargo.toml30
1 files changed, 30 insertions, 0 deletions
diff --git a/crates/ra_project_model/Cargo.toml b/crates/ra_project_model/Cargo.toml
new file mode 100644
index 000000000..5215e5232
--- /dev/null
+++ b/crates/ra_project_model/Cargo.toml
@@ -0,0 +1,30 @@
1[package]
2edition = "2018"
3name = "ra_project_model"
4version = "0.1.0"
5authors = ["Aleksey Kladov <[email protected]>"]
6
7[dependencies]
8# itertools = "0.8.0"
9# join_to_string = "0.1.3"
10# log = "0.4.5"
11# relative-path = "0.4.0"
12# rayon = "1.0.2"
13# fst = "0.3.1"
14rustc-hash = "1.0"
15# parking_lot = "0.7.0"
16# unicase = "2.2.0"
17
18# TODO get rid of these?
19failure = "0.1.4"
20failure_derive = "0.1.4"
21
22smol_str = { version = "0.1.9", features = ["serde"] }
23walkdir = "2.2.7"
24
25cargo_metadata = "0.7.0"
26
27ra_arena = { path = "../ra_arena" }
28
29[dev-dependencies]
30test_utils = { path = "../test_utils" }