aboutsummaryrefslogtreecommitdiff
path: root/crates/ra_syntax/Cargo.toml
diff options
context:
space:
mode:
authorAleksey Kladov <[email protected]>2019-01-11 10:21:18 +0000
committerAleksey Kladov <[email protected]>2019-01-11 10:21:18 +0000
commit66d7adf1cbbe727bfdef6db3fbf8d15bc0e747df (patch)
tree3f01166b8148b0703a6318662bbd93c51a2aa3e8 /crates/ra_syntax/Cargo.toml
parent28559b7dd2e2c101c4b7f2c9bb207b3af94f6e16 (diff)
force serde in ra_syntax
Diffstat (limited to 'crates/ra_syntax/Cargo.toml')
-rw-r--r--crates/ra_syntax/Cargo.toml7
1 files changed, 6 insertions, 1 deletions
diff --git a/crates/ra_syntax/Cargo.toml b/crates/ra_syntax/Cargo.toml
index 7c8e5b696..d5b4a4a77 100644
--- a/crates/ra_syntax/Cargo.toml
+++ b/crates/ra_syntax/Cargo.toml
@@ -14,7 +14,12 @@ itertools = "0.8.0"
14drop_bomb = "0.1.4" 14drop_bomb = "0.1.4"
15parking_lot = "0.7.0" 15parking_lot = "0.7.0"
16rowan = "0.2.0" 16rowan = "0.2.0"
17text_unit = "0.1.6" 17
18# ideally, `serde` should be enabled by `ra_lsp_serder`, but we enable it here
19# to reduce number of compilations
20text_unit = { version = "0.1.6", features = ["serde"] }
21smol_str = { version = "0.1.9", features = ["serde"] }
22
18ra_text_edit = { path = "../ra_text_edit" } 23ra_text_edit = { path = "../ra_text_edit" }
19 24
20[dev-dependencies] 25[dev-dependencies]