aboutsummaryrefslogtreecommitdiff
path: root/crates/ra_syntax/Cargo.toml
diff options
context:
space:
mode:
authorAleksey Kladov <[email protected]>2019-01-26 16:39:31 +0000
committerAleksey Kladov <[email protected]>2019-01-26 16:39:31 +0000
commit6f862a670439a0ca1a4b78c02569ce6ecdffdf53 (patch)
tree99a33f7028df8e3c653339ca83f753c8fa1f3f0c /crates/ra_syntax/Cargo.toml
parenta8d32c4d1ae4b3e4276f7a97b6c6e5f95f91e67a (diff)
:arrow_up: rowan
The new rowan uses arena allocator for red nodes which helps slightly (5% on std completion test) with performance but should help quite a bit with avoiding memory fragmentation.
Diffstat (limited to 'crates/ra_syntax/Cargo.toml')
-rw-r--r--crates/ra_syntax/Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/crates/ra_syntax/Cargo.toml b/crates/ra_syntax/Cargo.toml
index c50dc6c67..0ec8492aa 100644
--- a/crates/ra_syntax/Cargo.toml
+++ b/crates/ra_syntax/Cargo.toml
@@ -13,7 +13,7 @@ unicode-xid = "0.1.0"
13itertools = "0.8.0" 13itertools = "0.8.0"
14drop_bomb = "0.1.4" 14drop_bomb = "0.1.4"
15parking_lot = "0.7.0" 15parking_lot = "0.7.0"
16rowan = "0.3.2" 16rowan = "0.3.3"
17 17
18# ideally, `serde` should be enabled by `ra_lsp_serder`, but we enable it here 18# ideally, `serde` should be enabled by `ra_lsp_serder`, but we enable it here
19# to reduce number of compilations 19# to reduce number of compilations