aboutsummaryrefslogtreecommitdiff
path: root/crates/ra_syntax/Cargo.toml
diff options
context:
space:
mode:
authorAleksey Kladov <[email protected]>2020-08-12 17:26:51 +0100
committerAleksey Kladov <[email protected]>2020-08-12 17:30:53 +0100
commita1c187eef3ba08076aedb5154929f7eda8d1b424 (patch)
tree9d898eb9600b0c36a74e4f95238f679c683fa566 /crates/ra_syntax/Cargo.toml
parent3d6889cba72a9d02199f7adaa2ecc69bc30af834 (diff)
Rename ra_syntax -> syntax
Diffstat (limited to 'crates/ra_syntax/Cargo.toml')
-rw-r--r--crates/ra_syntax/Cargo.toml36
1 files changed, 0 insertions, 36 deletions
diff --git a/crates/ra_syntax/Cargo.toml b/crates/ra_syntax/Cargo.toml
deleted file mode 100644
index eec4bd845..000000000
--- a/crates/ra_syntax/Cargo.toml
+++ /dev/null
@@ -1,36 +0,0 @@
1[package]
2edition = "2018"
3name = "ra_syntax"
4version = "0.1.0"
5authors = ["rust-analyzer developers"]
6license = "MIT OR Apache-2.0"
7description = "Comment and whitespace preserving parser for the Rust language"
8repository = "https://github.com/rust-analyzer/rust-analyzer"
9
10[lib]
11doctest = false
12
13[dependencies]
14itertools = "0.9.0"
15rowan = "0.10.0"
16rustc_lexer = { version = "671.0.0", package = "rustc-ap-rustc_lexer" }
17rustc-hash = "1.1.0"
18arrayvec = "0.5.1"
19once_cell = "1.3.1"
20
21stdx = { path = "../stdx" }
22
23text_edit = { path = "../text_edit" }
24parser = { path = "../parser" }
25
26# This crate transitively depends on `smol_str` via `rowan`.
27# ideally, `serde` should be enabled by `rust-analyzer`, but we enable it here
28# to reduce number of compilations
29smol_str = { version = "0.1.15", features = ["serde"] }
30serde = { version = "1.0.106", features = ["derive"] }
31
32[dev-dependencies]
33test_utils = { path = "../test_utils" }
34expect = { path = "../expect" }
35walkdir = "2.3.1"
36rayon = "1"