aboutsummaryrefslogtreecommitdiff
path: root/crates/ra_syntax/Cargo.toml
diff options
context:
space:
mode:
authorShotaro Yamada <[email protected]>2019-07-08 16:28:00 +0100
committerShotaro Yamada <[email protected]>2019-07-08 16:28:00 +0100
commita426de60ad2b4e7041f8fd8ff97b10f97d8bbfd1 (patch)
tree7bb279168cbf12d203bc211168b7f2f782493839 /crates/ra_syntax/Cargo.toml
parent64b718bff7df788bfe6e8e2dce24b20faf9be235 (diff)
Remove unused dependencies
Diffstat (limited to 'crates/ra_syntax/Cargo.toml')
-rw-r--r--crates/ra_syntax/Cargo.toml3
1 files changed, 0 insertions, 3 deletions
diff --git a/crates/ra_syntax/Cargo.toml b/crates/ra_syntax/Cargo.toml
index 156991358..37a91ea35 100644
--- a/crates/ra_syntax/Cargo.toml
+++ b/crates/ra_syntax/Cargo.toml
@@ -8,15 +8,12 @@ description = "Comment and whitespace preserving parser for the Rust langauge"
8repository = "https://github.com/rust-analyzer/rust-analyzer" 8repository = "https://github.com/rust-analyzer/rust-analyzer"
9 9
10[dependencies] 10[dependencies]
11arrayvec = "0.4.10"
12unicode-xid = "0.1.0" 11unicode-xid = "0.1.0"
13itertools = "0.8.0" 12itertools = "0.8.0"
14drop_bomb = "0.1.4"
15rowan = "0.5.0" 13rowan = "0.5.0"
16 14
17# ideally, `serde` should be enabled by `ra_lsp_server`, but we enable it here 15# ideally, `serde` should be enabled by `ra_lsp_server`, but we enable it here
18# to reduce number of compilations 16# to reduce number of compilations
19text_unit = { version = "0.1.8", features = ["serde"] }
20smol_str = { version = "0.1.12", features = ["serde"] } 17smol_str = { version = "0.1.12", features = ["serde"] }
21 18
22ra_text_edit = { path = "../ra_text_edit" } 19ra_text_edit = { path = "../ra_text_edit" }