aboutsummaryrefslogtreecommitdiff
path: root/crates/ra_syntax/Cargo.toml
diff options
context:
space:
mode:
authorAleksey Kladov <[email protected]>2019-12-12 13:11:06 +0000
committerAleksey Kladov <[email protected]>2019-12-12 13:11:06 +0000
commitb0739d5a26684527129882b7d182d01e635525bc (patch)
tree142fd65a2f1f8455c2ae2453dfdc575dee9d5e11 /crates/ra_syntax/Cargo.toml
parent4444192b05c107a40a5a05ea3c9091ad8f8cbbcc (diff)
Avoid recompiling serde
Diffstat (limited to 'crates/ra_syntax/Cargo.toml')
-rw-r--r--crates/ra_syntax/Cargo.toml7
1 files changed, 4 insertions, 3 deletions
diff --git a/crates/ra_syntax/Cargo.toml b/crates/ra_syntax/Cargo.toml
index 1c0b184e1..b6ebb129d 100644
--- a/crates/ra_syntax/Cargo.toml
+++ b/crates/ra_syntax/Cargo.toml
@@ -18,13 +18,14 @@ rustc-hash = "1.0.1"
18arrayvec = "0.5.1" 18arrayvec = "0.5.1"
19once_cell = "1.2.0" 19once_cell = "1.2.0"
20 20
21ra_text_edit = { path = "../ra_text_edit" }
22ra_parser = { path = "../ra_parser" }
23
21# This crate transitively depends on `smol_str` via `rowan`. 24# This crate transitively depends on `smol_str` via `rowan`.
22# ideally, `serde` should be enabled by `ra_lsp_server`, but we enable it here 25# ideally, `serde` should be enabled by `ra_lsp_server`, but we enable it here
23# to reduce number of compilations 26# to reduce number of compilations
24smol_str = { version = "0.1.12", features = ["serde"] } 27smol_str = { version = "0.1.12", features = ["serde"] }
25 28serde = { version = "1", features = ["derive"] }
26ra_text_edit = { path = "../ra_text_edit" }
27ra_parser = { path = "../ra_parser" }
28 29
29[dev-dependencies] 30[dev-dependencies]
30test_utils = { path = "../test_utils" } 31test_utils = { path = "../test_utils" }