aboutsummaryrefslogtreecommitdiff
path: root/crates/ra_syntax/Cargo.toml
diff options
context:
space:
mode:
authorKirill Bulatov <[email protected]>2020-02-18 13:57:41 +0000
committerKirill Bulatov <[email protected]>2020-02-18 14:12:40 +0000
commitf6816c253b96e8436f1156d6bd6b0942ee9fb4d3 (patch)
tree37c8dde0a459caacae6629da08d86be270469ef5 /crates/ra_syntax/Cargo.toml
parenteceaf94f1936436e33ae235ca65bf2a6d4f77da5 (diff)
Update versions
Diffstat (limited to 'crates/ra_syntax/Cargo.toml')
-rw-r--r--crates/ra_syntax/Cargo.toml12
1 files changed, 6 insertions, 6 deletions
diff --git a/crates/ra_syntax/Cargo.toml b/crates/ra_syntax/Cargo.toml
index cb72972c5..7891628dc 100644
--- a/crates/ra_syntax/Cargo.toml
+++ b/crates/ra_syntax/Cargo.toml
@@ -11,12 +11,12 @@ repository = "https://github.com/rust-analyzer/rust-analyzer"
11doctest = false 11doctest = false
12 12
13[dependencies] 13[dependencies]
14itertools = "0.8.0" 14itertools = "0.8.2"
15rowan = "0.9.0" 15rowan = "0.9.0"
16rustc_lexer = "0.1.0" 16rustc_lexer = "0.1.0"
17rustc-hash = "1.0.1" 17rustc-hash = "1.1.0"
18arrayvec = "0.5.1" 18arrayvec = "0.5.1"
19once_cell = "1.2.0" 19once_cell = "1.3.1"
20 20
21ra_text_edit = { path = "../ra_text_edit" } 21ra_text_edit = { path = "../ra_text_edit" }
22ra_parser = { path = "../ra_parser" } 22ra_parser = { path = "../ra_parser" }
@@ -24,9 +24,9 @@ ra_parser = { path = "../ra_parser" }
24# This crate transitively depends on `smol_str` via `rowan`. 24# This crate transitively depends on `smol_str` via `rowan`.
25# ideally, `serde` should be enabled by `rust-analyzer`, but we enable it here 25# ideally, `serde` should be enabled by `rust-analyzer`, but we enable it here
26# to reduce number of compilations 26# to reduce number of compilations
27smol_str = { version = "0.1.12", features = ["serde"] } 27smol_str = { version = "0.1.15", features = ["serde"] }
28serde = { version = "1", features = ["derive"] } 28serde = { version = "1.0.104", features = ["derive"] }
29 29
30[dev-dependencies] 30[dev-dependencies]
31test_utils = { path = "../test_utils" } 31test_utils = { path = "../test_utils" }
32walkdir = "2.2.0" 32walkdir = "2.3.1"