aboutsummaryrefslogtreecommitdiff
path: root/crates/ra_syntax/fuzz/Cargo.toml
diff options
context:
space:
mode:
authorpcpthm <[email protected]>2019-03-21 17:06:48 +0000
committerpcpthm <[email protected]>2019-03-21 23:04:48 +0000
commit4c7142d0c9be90c8947deb788993d903b2e0a5d1 (patch)
tree0fc0ebe4aa7918e39b4e95d23ad192a0734f339a /crates/ra_syntax/fuzz/Cargo.toml
parente734190c24d2a5aca5b62c2b1ab7e6136017a25c (diff)
Add fuzz test for reparsing
Diffstat (limited to 'crates/ra_syntax/fuzz/Cargo.toml')
-rw-r--r--crates/ra_syntax/fuzz/Cargo.toml5
1 files changed, 5 insertions, 0 deletions
diff --git a/crates/ra_syntax/fuzz/Cargo.toml b/crates/ra_syntax/fuzz/Cargo.toml
index c54d12813..613ad2857 100644
--- a/crates/ra_syntax/fuzz/Cargo.toml
+++ b/crates/ra_syntax/fuzz/Cargo.toml
@@ -11,6 +11,7 @@ cargo-fuzz = true
11 11
12[dependencies] 12[dependencies]
13ra_syntax = { path = ".." } 13ra_syntax = { path = ".." }
14ra_text_edit = { path = "../../ra_text_edit" }
14libfuzzer-sys = { git = "https://github.com/rust-fuzz/libfuzzer-sys.git" } 15libfuzzer-sys = { git = "https://github.com/rust-fuzz/libfuzzer-sys.git" }
15 16
16# Prevent this from interfering with workspaces 17# Prevent this from interfering with workspaces
@@ -20,3 +21,7 @@ members = ["."]
20[[bin]] 21[[bin]]
21name = "parser" 22name = "parser"
22path = "fuzz_targets/parser.rs" 23path = "fuzz_targets/parser.rs"
24
25[[bin]]
26name = "reparse"
27path = "fuzz_targets/reparse.rs"